Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
ValkyrieReign

Poor connection times / Loading speed of matches on the east coast of Australia ISP's fault or games who knows ?!

9 comments in this topic

Recommended Posts

Member
2 posts

Since this is my first forum post I will make this simple connection times in Australia especially the east coast where there is no national broadband network access available is atrocious for this game now whether that is the games fault or the ISP I am with I do not know but if there is any way to improve it on the games side it would be greatly appreciated.

 

For example it can anywhere from thirty seconds to a minute and half to load in to the match which is especially infuriating when your driving super slow ships and your miles behind the rest of the team right off the bat.

 

I am not complaining as much as I am hoping for improvements in regards to this sort of stuff so do not take what I've said out of its original context :)

Edited by Panz3rJaegerAbteilung506

Share this post


Link to post
Share on other sites
Senior Moderator
3,837 posts
2,602 battles

That is a game performance issue, not a connection issue. The game's resource packaging aren't well optimized yet and is something that the devs are still working on. The only way to improve it on your end is to use lower graphic settings and/or use SSD or RAM disk. Other than that, you'll just have to wait until the devs optimize the game.

Share this post


Link to post
Share on other sites
Member
91 posts
7,169 battles

I'm living in Victoria now and sometimes I experienced weird lag, it was like the ping was okay (around 130) and stable (no orange beep beep) but the screen fluctuated like sea sick and I couldnt aim and shoot properly.

Share this post


Link to post
Share on other sites
Super Tester
2,725 posts

Since this is my first forum post I will make this simple connection times in Australia especially the east coast where there is no national broadband network access available is atrocious for this game now whether that is the games fault or the ISP I am with I do not know but if there is any way to improve it on the games side it would be greatly appreciated.

 

For example it can anywhere from thirty seconds to a minute and half to load in to the match which is especially infuriating when your driving super slow ships and your miles behind the rest of the team right off the bat.

 

I am not complaining as much as I am hoping for improvements in regards to this sort of stuff so do not take what I've said out of its original context :)

 

Like amade said,long loading time into the battle is related to your computer performance and not the internet speed. Care to post your computer specifications? :)

Share this post


Link to post
Share on other sites
Alpha Tester
512 posts
308 battles

Other than that, you'll just have to wait until the devs optimize the game.

 

Though if it's anything like wot's optimisation don't expect much in the way of improvements.

Share this post


Link to post
Share on other sites
Super Tester
802 posts

Is the cable from Perth to Singapore still SNAFU? That can't be helping, either.

 

I tried playing earlier today. Laggy as hell, then got booted.

 

Confirmed, SEA-ME-WE 3 cable that connects Western Australia to Singapore is kill (again)

 

http://www.itnews.com.au/news/cut-submarine-cable-cripples-apple-services-for-telstra-customers-410006

 

and I optimized the game according to Geforce experience recommendation and also have SSD by the way

 

Your hardware will have nothing to do with latency to the server, unlike OP's issue. Although given you haven't posted any hardware specs other than that you have an SSD (Which in reality will only effect load times) who is to say?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×