Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Ergo_Proxy

Connection Issues here in Philippines

10 comments in this topic

Recommended Posts

Member
1 post
377 battles

Hello there I need help. I kept on reinstalling my client game of WOWS but it keeps lagging while I'm playing and then I always end up on the log in screen after a long lag, is there a problem with the server here in Philippines? Or Is there any connection problem in other servers. I need to know.

Share this post


Link to post
Share on other sites
Member
575 posts
5,354 battles

Hey all, who are you using for an ISP? I'm using Globe's ADSL2 and I'm not having an issue. I'm seeing 35 - 50ms pings. There are some short lag spikes or ping increases, but no major problems.

Share this post


Link to post
Share on other sites
Member
4 posts

same issue here.. already submitted a ticket to WG, fifth day still in queue. 

 

my ticket was answered already.. unfortunately as per WG my hardware is not compatible to run the game. i feel so defeated and this really makes me sad. waited a year for this game to show up here in sout east asia only to find out that the same machine im using to play wot is not enough for their wows.

Share this post


Link to post
Share on other sites
Member
2 posts
258 battles

Even here if both party will meet each other then that's the time the problem occur lag connection an d FPS drop to 1 .... I'm using ATI Radeon 270x Video Card and 16 Gig Ram and A4 Processor. 

Share this post


Link to post
Share on other sites
Member
4 posts

Even here if both party will meet each other then that's the time the problem occur lag connection an d FPS drop to 1 .... I'm using ATI Radeon 270x Video Card and 16 Gig Ram and A4 Processor. 

 

that's exactly what i have been experiencing. only when both team starts to clash thats where my ping goes up to 500+ ms

Share this post


Link to post
Share on other sites
Member
2 posts
258 battles

 

that's exactly what i have been experiencing. only when both team starts to clash thats where my ping goes up to 500+ ms

 

Same on WOT also FPS drop and Ping increase were both teams start to clash. Since 2011 I play this game the WOT and now WOW but the thing I feel dismay with the graphics demand  and I think only Rich player can play this games.. 

Share this post


Link to post
Share on other sites
Member
4 posts

 

Same on WOT also FPS drop and Ping increase were both teams start to clash. Since 2011 I play this game the WOT and now WOW but the thing I feel dismay with the graphics demand  and I think only Rich player can play this games.. 

 

couldn't agree more. also WG doesn't care about the small fry's like us. 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×