Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
AoSuRa

同期ズレについて

4 comments in this topic

Recommended Posts

Member
4 posts
169 battles

不具合報告でもさせて頂いたのですが、現在、戦闘中に「同期ズレ」が発生する状況にあります。

個人で発生する人/しない人があるようです。

 

一体どのくらいの人が同期ズレしているのかちょっと知りたいと思ってトピックを立てました。(ココで立てるべきか迷いましたが・・沢山の人が閲覧してると思いましたので)

皆さんどうでしょう?下記のような症状を経験した方は書き込んでくれると幸いです。

 

・明らかに敵艦(自艦)に砲弾(魚雷)が当たっている筈なのに、衝突判定が出ずにすり抜ける。

敵艦(自艦)への着弾エフェクトが何も無い場所で描画される。

・撃沈時には、それまで航行していた位置から急にワープして描画される。

・艦船の操舵の効きが明らかに重い(めいいっぱい転舵操作をして数秒後にやっと艦船が曲がり始めるなど)

・砲が発射できる状態(照準マークが緑色)なのに、操作しても発射されない

・何だかよくわからないけど、どう考えても艦船の位置ズレて描画されてる

 
また不具合報告のトピックでも状況を書き込んでいただけると運営も改善し易いかと思いますので、可能であればお願いいたします。

Share this post


Link to post
Share on other sites
Beta Tester
649 posts
306 battles

MMOで「同期ズレ」が起こる原因のひとつはクライアント側(プレイヤー本人)とサーバーを結ぶ回線に大きなラグが発生する場合です。

見分け方としては、次のようなものが考えられます。

 

・画面左上のPing数値は極端に変化していませんか?常時2桁だったのが3桁に増えてそのまま続くとか。

・Ping数値の右隣に赤いランプが点灯してLagと表示されませんか?瞬間的に点灯するのではなく、ある程度の秒数点灯したままとか。

・他の艦の動きはどうですか?仮にあなたの側の回線が原因とすると、他のプレイヤーの攻撃・被弾状況はサーバーと正常にやりとりできていると

 仮定できます。だとするとあなたから見ても他のプレイヤーの攻撃や着弾は「ズレていない」はずです。

 逆に、どの艦もあなたと同様に着弾・触雷・艦の位置がズレて表示されるとすると、むしろサーバー側に処理遅延のような原因が考えられます。

このあたりを、もう一度観察してみてください。

 

また、WoTでも夜の時間帯には全員にラグが発生するという事象がありました。この時はWoTのアジアサーバーがあるシンガポールのノードで

重大な遅延が発生していることがプレイヤーにより確認されています。

※PingPlotterというツールで計測するのですが、詳しいことは忘れてしまいました。WoTの時は計測ターゲット名を"login.worldoftanks.asia"として

動作させると、回線上の各ノードの遅延時間がわかります。WoWsのアジアサーバーがどこにあるかは・・・ググってみてください。

 

※なお、リプレイファイルを保存しておいてそれを再生すると、開幕の時点から数秒のズレが発生するようです。以後、すべての事象がズレて見えます。

 これはリプレイに起因する別問題です。リプレイ中はPingは1msで表示されます。

Share this post


Link to post
Share on other sites
ST Coordinator
575 posts
5,404 battles

関連する不具合報告のスレッド

戦闘中の同期ずれ

 

私の環境で発生した際には、ping等の回線状況の悪化などは計測できる範囲では確認できませんでした。

結局何が原因だったのかわかりません。

 

最近0405アップデートなどでマイナーなバグ(同期ずれに関するものかどうかは不明)が修正されたようですが、AoSuRaさんはその後も継続して症状が発生してらっしゃるのでしょうか?

Share this post


Link to post
Share on other sites
Member
4 posts
169 battles

 

Leona_Ozakiさん、tomato432さん情報ありがとうございます。

 

>・画面左上のPing数値は極端に変化していませんか?常時2桁だったのが3桁に増えてそのまま続くとか。

>・Ping数値の右隣に赤いランプが点灯してLagと表示されませんか?瞬間的に点灯するのではなく、

確認してみましたが、Pingは大体30~45辺りで落ち着いており、Lagランプも点滅はしますが、頻発/常時点灯はしないようです。

>・他の艦の動きはどうですか?

他の人達は特に問題なくプレイできているようです。友人と小隊を組んでいたときも、友人は正常でした。

しかし、私から見るとやっぱり全ての艦がズレて描画されていました。

 

>最近0405アップデートなどでマイナーなバグ(同期ずれに関するものかどうかは不明)が修正

その様ですが、こちらの環境では同期ズレは改善されてないようです。


再インストールもしてみましたが、改善しないようでした。

なんでしょうかね・・ 自分だけのようですから特別自回線だけに問題が発生しているのかも?

もう少し調べてみます。何かあればまたご報告いたします。

 

Edited by AoSuRa

Share this post


Link to post
Share on other sites
Sign in to follow this  

×