Jump to content
You need to play a total of 10 battles to post in this section.
lastfight5

Problems connecting with the server

20 comments in this topic

Recommended Posts

Member
12 posts
575 battles

So lately I've been trying to play World of Warships and whenever I attempt to log in, it says "Failed to Connect to the Server."

I looked at the latest news and it said that there was a maintenance done not long ago. I thought "maybe there's still maintenance", so I waited out, came back and it still says "Failed to Connect".

Then I checked for answers. They said that it maybe the server is offline or something. I checked the main page and it said that the server is available with over 10,000 players playing. I went back, "Failed to Connect."

Finally, I just said [content removed], restarted my computer, came back and guess what: "Failed to Connect."

I really need help what's going on.

 

Profanity. Content removed, user warned.

~Noppers

Edited by Noppers

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

About 9600 players currently connected to the server right now, so it's up. Check to see if your antivirus/firewall may be blocking connections to the server.

Share this post


Link to post
Share on other sites
Member
12 posts
575 battles

About 9600 players currently connected to the server right now, so it's up. Check to see if your antivirus/firewall may be blocking connections to the server.

 

Not really. Checked Firewall, nothing wrong with World of Warships. Also, I'm very aware that the server is up, hence I said, "...said that the server is available with over 10,000 players playing."

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

If you're absolutely sure it's not your antivirus, try a tracert or pingplot to login.worldofwarships.jp and see if you're suffering packet loss on the way.

Share this post


Link to post
Share on other sites
Member
12 posts
575 battles

Try the obvious - restart everything - PC, Router, Modem etc.

 

Already done all that, guess what: Failed to Connect.

 

Also I came back after one whole day and it still presented me with that. Is this a server problem or something

 

EDIT: I've done it again, still says "Failed to Connect"

Edited by lastfight5

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

 

Already done all that, guess what: Failed to Connect.

 

Also I came back after one whole day and it still presented me with that. Is this a server problem or something

 

EDIT: I've done it again, still says "Failed to Connect"

 

Server is up with 17k players. So no, not likely to be a server problem.

 

My guess? It's your antivirus or router settings, because that would be the only reason it'd throw up a "Failed to Connect" message.

Share this post


Link to post
Share on other sites
Member
12 posts
575 battles

 

Server is up with 17k players. So no, not likely to be a server problem.

 

My guess? It's your antivirus or router settings, because that would be the only reason it'd throw up a "Failed to Connect" message.

 

I checked everything, my antivirus, router, anything, nothing wrong. And yet, it still says "Failed to Connect". I restarted everything, "Failed to Connect". Basically, I've done everything you said, everything I've searched, they all don't work and still says "Failed to Connect". I even sent a ticket for this.

 

But does that mean I had to reinstall everything

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

 

I checked everything, my antivirus, router, anything, nothing wrong. And yet, it still says "Failed to Connect". I restarted everything, "Failed to Connect". Basically, I've done everything you said, everything I've searched, they all don't work and still says "Failed to Connect". I even sent a ticket for this.

 

But does that mean I had to reinstall everything

 

Reinstall your antivirus.

Share this post


Link to post
Share on other sites
Member
12 posts
575 battles

 

Reinstall your antivirus.

 

Wouldn't that work? After all, my anti-virus doesn't have much long as you think. If I attempt to reinstall it, I might succeed in deleting it only

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

 

Wouldn't that work? After all, my anti-virus doesn't have much long as you think. If I attempt to reinstall it, I might succeed in deleting it only

 

There are quite a few free antivirus programs out there that are better than the default subscription ones, such as AVG, Avast, Kaspersky, etc. Even if you end up deleting your antivirus, you could just easily replace it.

Share this post


Link to post
Share on other sites
Member
12 posts
575 battles

 

There are quite a few free antivirus programs out there that are better than the default subscription ones, such as AVG, Avast, Kaspersky, etc. Even if you end up deleting your antivirus, you could just easily replace it.

 

I can't risk deleting my anti-virus, especially since it's Norton. Besides, I find some antivirus unreliable and more of an annoyance. Also, I don't think the anti-virus was the problem. The antivirus detected World of Warships and declared it was fine. So I don't get why I'm constantly barred from playing the game. This is the second day and I still can't get in. All the solutions I find and you guys offered went nought. I'm still waiting on the ticket

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

 

I can't risk deleting my anti-virus, especially since it's Norton. Besides, I find some antivirus unreliable and more of an annoyance. Also, I don't think the anti-virus was the problem. The antivirus detected World of Warships and declared it was fine. So I don't get why I'm constantly barred from playing the game. This is the second day and I still can't get in. All the solutions I find and you guys offered went nought. I'm still waiting on the ticket

 

Look, if you want to try playing the game, then you can try troubleshooting by uninstalling Norton and checking if its your firewall or antivirus killing the game connection, because in my experience, seeing that "Failed to Connect" message when the server is up means either your router, antivirus or firewall is killing the connection. Otherwise, pretty much nothing else will solve your issue.

Share this post


Link to post
Share on other sites
Member
12 posts
575 battles

 

Look, if you want to try playing the game, then you can try troubleshooting by uninstalling Norton and checking if its your firewall or antivirus killing the game connection, because in my experience, seeing that "Failed to Connect" message when the server is up means either your router, antivirus or firewall is killing the connection. Otherwise, pretty much nothing else will solve your issue.

 

Norton's pre-downloaded when I had this computer. If I reinstall it, I can't get it back as I don't have the account number and stuff.

 

EDIT: Not even Norton wants to help me. I tried opening it or even reinstall it, it refuses

Edited by lastfight5

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

 

There are quite a few free antivirus programs out there that are better than the default subscription ones, such as AVG, Avast, Kaspersky, etc. Even if you end up deleting your antivirus, you could just easily replace it.

 

Share this post


Link to post
Share on other sites

×