Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
ChiefGunner77

have someone else's profile help!

7 comments in this topic

Recommended Posts

Beta Tester
2 posts
137 battles

I just logged on and got the update. went to play game and noticed I had twice as much exchange credits and XP. looked a little closer and saw American cruisers (When I run with Japanese Battleships) no trophies, settings different, no battle record at all etc. Looked up at my name and it is the only thing that is right. I logged out and logged back in and got the same results. Anyone seen this before or know any fixes. It sucks as that is a lot of time lost. totally weird. Thanks in advance for the help.

Edited by ChiefGunner77

Share this post


Link to post
Share on other sites
Alpha Tester
523 posts
217 battles

Im guessing you havent played in some weeks? Progress was reset after the update, WG had made this clear in advance. The good news is no more resets after this, and you should have a shiny tier 4 BB gift from WG as well.

Share this post


Link to post
Share on other sites
Super Tester
2,725 posts

Yup, checked this guy's account and he is 20 days late of the news.

 

There's been a wipe after Closed Beta Test which is June 28, and it went official Open Beta Test on July 1. So... we're going back to zero as equal footing at the start of the Open Beta.

Share this post


Link to post
Share on other sites
Beta Tester
2 posts
137 battles

Thanks everyone, I have been off for some time now. work sucks! so does the wipe but it is good to know that I'm not broke. Again appreciate the help. keep your powder dry and your rounds on target. Fair winds and following seas!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×