Jump to content
You need to play a total of 10 battles to post in this section.
Captain_Ivanov

Can I run this game?

8 comments in this topic

Recommended Posts

Member
10 posts
135 battles

ttHi guys I'm Ivanov and I'm new to this games, I downloaded it last night and it's fun to play, one thing annoys me is the graphics.

Here is my computer stats 

Windows7, 32bit

i7 CPU quadcore

8G RAM

AMD7470M Graphic 

I tried Low graphics and it's constantly giving me FPS spikes, from 46FPS~3FPS

Tried medium,

It even lags like hell in the port.

In another game which is similar like World of Tanks and World of Warplanes but I'm not going to say it's name just in case this topic get locked, I get 60FPS on "Medium" settings.

Is this a bug, or is it just my computer is not enough to run this game smoothly?

 

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

You should be able to run the game. From what I've heard, though, World of Warships doesn't play nicely with AMD Crossfire, so that might be the issue.

Share this post


Link to post
Share on other sites
Member
10 posts
135 battles

You should be able to run the game. From what I've heard, though, World of Warships doesn't play nicely with AMD Crossfire, so that might be the issue.

 

;_; but but

Is there a way for me to fix it?

I really like this game I even bought the Aurora to show my loyalty to glorious red navy :D

Is there a way to improve graphics?

Thanks

 

Edited by Captain_Ivanov

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

You could try disabling Crossfire - might be a tutorial floating around out there to tell you how to do it. Alternatively, tweak the game settings lower and see if it helps.

Share this post


Link to post
Share on other sites
Member
10 posts
135 battles

You could try disabling Crossfire - might be a tutorial floating around out there to tell you how to do it. Alternatively, tweak the game settings lower and see if it helps.

 

Yes indeed turning lower works

I got 3FPS 

And the ships looks like rubber ducks and still lags

And how do I turn off crossfire?

спасибо o7

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

 To disable Crossfire right-click your desktop and select "Catalyst Control Center". On the upper-left click "Graphics", then "CrossfireX". In the main area of the window, uncheck the "Enable Crossfire" option. Click "OK" to accept the changes and close the Control Center

 

Should be this.

Share this post


Link to post
Share on other sites

×