Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Morphious_Tank_MK2

Performance Issues and Server Lag

3 comments in this topic

Recommended Posts

Member
2 posts
1,356 battles

I started playing when the open beta came out and I was really excited, however, once I got into the game it was a different story, I found myself having serious lag issues where seconds could go by and then all of a sudden I would jump to another location or find myself back at the login page, this needs to be fixed, an upgrade on the server capacity perhaps? Another problem I've been having is with performance, even with all graphics and sound set to their lowest levels I am still experiencing terrible frame rates, often 5 to 10 frames per second, I know my computer just barely meets the minimum requirements for gameplay but still, this needs to be fixed, can anything be done about it?

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

Would be useful if you provided more information. Please list your system specs, as well as the connection typeWhat kind of lag are you experiencing? Video lag? Audio stuttering? What is your latency in battle? Is the lag indicator (next to your ping) lit up red?

 

Also, if your computer barely meets the minimum requirements, it's not the fault of the game if you are experiencing visual lag or disconnects. Server capacity isn't an issue - I've been logged onto the game more or less constantly since signups open and apart from a short period at the start of unofficial OBT, my latency has been steady at 30-50ms.

Edited by Syanda

Share this post


Link to post
Share on other sites
Member
13 posts
118 battles

5-10 fps on lowest settings is so bad

i think that your computer is far below the minimum requirments

Share this post


Link to post
Share on other sites
Sign in to follow this  

×