Jump to content
Sign in to follow this  
DirectorOfFish

PT client consumes all system memory after battle start

3 comments in this topic

Recommended Posts

0
[LBAS]
Member
3 posts
4,022 battles

1. Description

After entering a battle, the PTS client will quickly start to consume large amounts of memory, until all system memory is exhausted.

 

2. Reproduction steps

Run task manager to observe memory consuption. Enter a co-op battle or create a training room and begin the battle. Problem will occur every time I try this. (But I assume nobody else is experiencing it...)

 

3. Result

Client uses approx 2GB of RAM while in port. After launching the battle, usage rapidly and dramatically increases until all memory is exhausted, the game begins to lag/jump, and will usually crash after around 5 minutes if not closed before this.

 

4. Expected result

Client will use only around 2-3 GB of RAM, and the amount will not increase noticeably as the battle goes on. (This is the behaviour I get in the regular non-test client.)

 

5. Technical details

The problem occurs regardless of graphical settings (turning everything to minimum made no difference).

After game crash, reconnecting to the battle in progress results in the same problem occurring, though occasionally to a lesser extent (one time I saw it stop at around 16GB of RAM used, after I reconnected near the end of a battle in progress)

It happened in every game I tried to play; I've attached the replays in case that will help.

I've attached the .crash files from the 'crashes' directory for the times the game actually crashed after running out of memory.

Also attaching python log and dxdiag log.

 

 

For now, with this issue, I simply can't play any games on PTS. Live server client works perfectly fine, though!

python.log

DxDiag.txt

mem_usage_24g.png

memory_graph.png

20210724_153829_PJSC009-Mogami-1935_35_NE_north_winter.wowsreplay

20210724_161547_PJSD108-Akizuki_46_Estuary.wowsreplay

20210724_172440_PJSD108-Akizuki_16_OC_bees_to_honey.wowsreplay

20210724_172919_PJSC009-Mogami-1935_00_CO_ocean.wowsreplay

20210730_195102_PJSC009-Mogami-1935_04_Archipelago.wowsreplay

crashes.zip

Share this post


Link to post
Share on other sites
0
[LBAS]
Member
3 posts
4,022 battles

The latest patch to PTS client seems to have fixed this issue (only tested in training room so far, but I don't expect the problem to be based on game type).

Share this post


Link to post
Share on other sites
Sign in to follow this  

×