Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Leviathon7881

Any players experience constant rubberbanding and DC from game play since early of this week?

4 comments in this topic

Recommended Posts

Member
32 posts

Since 7/12/2020 till now, i am experiencing constant rubberbanding and DC from game play, and this really kill the mood to continue playing WOW.  Anyone expwrience the same issue as me for this whole week?

Share this post


Link to post
Share on other sites
1,822
[151ST]
Member
2,960 posts
11,051 battles

I haven't had disconnects but there's been a lot more desync (rubberbanding) lately...

That moment when the ship that dies teleports forward half a ship-length... ...

Share this post


Link to post
Share on other sites
764
[SMOKE]
Member
2,190 posts
17,088 battles

Been happening regularly this week, to the point that I just stop playing quite a few times

Share this post


Link to post
Share on other sites
39
[NOOB1]
Member
113 posts
6,983 battles

I contacted WG about server performance - they said everything is working as intended ;

Funny  that was the same response I got from them when I queried Santa Crate drops.

Then WG went from 'working as intended' to refund with conditions when the Fiasco broke over their heads

Probably pays to cause a stink ` as the squeaky wheel gets the oil.

Problem is there is no Viacom watching from the side asking uncomfortable questions

WG will do the minimum they can get away with always 

and that includes server performance

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×