Jump to content
You need to play a total of 10 battles to post in this section.
Sulwind

Download WoWS

22 comments in this topic

Recommended Posts

0
[WORLD]
Beta Tester
26 posts
7,616 battles

Hi Guys, where can I DL WoWS for Asian Server?

I just brought prem ship's for CBT


 

Cheers Sulwind

Share this post


Link to post
Share on other sites
Alpha Tester
6,604 posts
2,477 battles

go to main page or portal, (login first), download the game, update the patch, Play with your lovely Prem ship

 

(If you still can't find it after login, look for "member page" left up corner of the page, Click download game, download the game, update the patch, Play with your lovely Prem ship)

Edited by Harpoon01

Share this post


Link to post
Share on other sites
0
[WORLD]
Beta Tester
26 posts
7,616 battles

Thxs mate, hadn't logged out and back in again so could see giant orange DL button LOL  :)

 

Share this post


Link to post
Share on other sites
Alpha Tester
6,604 posts
2,477 battles

actually I'm just about to say:

 

If you still can't find it even after you login at the main website, you need to go to the doctor.... Immediately 

Share this post


Link to post
Share on other sites
Beta Tester
1,007 posts
2,333 battles

actually I'm just about to say:

 

If you still can't find it even after you login at the main website, you need to go to the doctor.... Immediately 

 

I can't find it.... halp me!...

Share this post


Link to post
Share on other sites
Beta Tester
9 posts
33 battles

Sorry if I'm reviving an old thread but I have a bit of a problem. I would start my own topic but the forum is saying my posting rights have been temporarily suspended (I'm guessing it's because I only made my account today).

 

My problem is that when ever I try to open the 7mb download from the WoWS website I get an error saying that the file is corrupted. I have tried downloading the file many many times but it still doesn't work.

 

My system is running windows 8.1 on a i7 4710HQ, 16gb Ram, GTX 970M.

I have also disabled windows smartscreen and firewall, as well as my antivirus and anything else I could think of that may be causing a problem.

 

If anyone has a fix for this it would be much appreciated, also a mirror upload of your installer would also be great for me to try.

 

Cheers

Share this post


Link to post
Share on other sites
Beta Tester
9 posts
33 battles

I managed to find the windows installer repair, it didn't work sadly. I would if I had another system around me right now. Would you be able to upload your installer as a .rar file??

Share this post


Link to post
Share on other sites
Alpha Tester
184 posts
2,083 battles

I can e-mail it to you, not at home right now(no zip software here). I have the installer though. If you feel ok about it, message me separately your e-mail ID.

Share this post


Link to post
Share on other sites
284
[PANZA]
Senior Moderator
820 posts
932 battles

DO you run a AV program or Internet Security suite and in that case, which one ? Have you scanned and checked your PC for malicious software recently ?

 

Share this post


Link to post
Share on other sites

×