Jump to content
Sign in to follow this  
ComradeLex

Game too lag after update

16 comments in this topic

Recommended Posts

Beta Tester
10 posts
791 battles

Okay, after i updated the client, then the game became more lag(especially during gameplay) and the ping reaches at 400-500, it also happened in my World of Tanks after i updated it. I tried playing other online games like War Thunder and League of Legends, but the ping is stable. So i want to know why and does other experiencing it also?

Edited by ComradeLex

Share this post


Link to post
Share on other sites
Beta Tester
1,007 posts
2,333 battles

Okay, after i updated the client, then the game became more lag(especially during gameplay) and the ping reaches at 400-500, it also happened in my World of Tanks after i updated it. I tried playing other online games like War Thunder and League of Legends, but the ping is stable. So i want to know why and does other experiencing it also?

I'm not lag. 

Maybe maybe the problem of server?

 

I think server is not the problem ( or is it? )

 

We'll wait for answer.

Share this post


Link to post
Share on other sites
Member
24 posts
145 battles

you should download AMD Catalyst 12.14 for x2 FPS and turn off your vSync

Edited by Magekov

Share this post


Link to post
Share on other sites
Beta Tester
1,007 posts
2,333 battles

you should download AMD Catalyst 12.14 for x2 FPS and turn off your vSync

 

does this affect the internet?

Share this post


Link to post
Share on other sites
Beta Tester
1,007 posts
2,333 battles

oh it's the internet lag :bajan:that make sense

in Philippines Low Frame is Called Lag XD

 

man.

Share this post


Link to post
Share on other sites
Beta Tester
87 posts
3,802 battles

you should download AMD Catalyst 12.14 for x2 FPS and turn off your vSync

 

So if i leave my vSync on and download this to x2 (20-30fps x 2)i ll gain back my normal fps(55-60)?

Share this post


Link to post
Share on other sites
Beta Tester
1 post
866 battles

I was doing fine until the patch that happened about three hours ago and now I'm getting major lag spikes. Location: Hong Kong. Before patch I had consistent 40ms. Now It spikes from 40ms to 140 ms and I get lots of chugging.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×