Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
mr_glitchy_R

WoWS down again?

9 comments in this topic

Recommended Posts

253
[-ISO-]
Member
883 posts
5,884 battles

Strangely it's happening again today at evening to night times. Yesterday was fine until I had a concern when I was logging into the game today. It took so long until 10 minutes later only to found my account failed to connect to the server. I tried again this night and it worked. But not for long. After entering the battle, I stuck at -35 ping and couldn't connect to the server again. I also couldn't connect to the forum and WoWS main website.

Share this post


Link to post
Share on other sites
390
[AN-DO]
Beta Tester
1,328 posts
5,035 battles

I got a severe lag atm it jumps from my normal 30 - 35 Ping to 200 - 400 ping for no reason.

Server is unstable as hell really.. they need to fix Client Stability.

Share this post


Link to post
Share on other sites
13
[TOGN]
[TOGN]
Member
38 posts
4,150 battles

I was in the middle of a battle last night when the game froze and everyone was disconnected at once.  I couldn't log back in so I gave up and did something else.

Share this post


Link to post
Share on other sites
367
[SMOKE]
Member
1,096 posts
12,631 battles

Do not have any issue yesterday but it was suppose to be down now for the patch update

  • Cool 1

Share this post


Link to post
Share on other sites
15
[SEARN]
Member
27 posts
17,152 battles

Pretty sure it's just the patch update this time  🙂

 

Share this post


Link to post
Share on other sites
Member
803 posts
3,491 battles

I have ran into another problem that the game update got stuck at "Checking Integrity" since 0541AM today.

Again, I have to dump the existing client and download a new one.

Edited by Project45_Opytny

Share this post


Link to post
Share on other sites
1,696
Member
3,575 posts
7,290 battles

Last night about 9:48 PM GMT +7 I encountered an issue where I couldn't access the forum at all. Main portal and game were normal, but not the Prem shop. Lasted roughly an hour. Checked, and service was indeed unavailable.

May be just emergency server maintenance that WG didn't notice us.

Edited by Paladinum
  • Cool 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

×