Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Brunswickz

Box letters problem

16 comments in this topic

Recommended Posts

32
[STEIN]
Member
128 posts
10,699 battles

I saw this on the Migration thread, it comes to my mind.

Why, after 4 years, this hasn't solved ?

I can't read Chinese, Thai, or Korean but at least i wish the game can show proper letters.

Better, if the game can include auto translate into the chat.

 

A game at android, anime version of z-world can do that. I don't remember the name.

People still having difficulties with the auto translate but it is much better.

My clan were consisted of people typing English, German, Brazilian Portugese, Spanish, South American Spanish, French, Bahasa, Swedish, Chinese and Japan.

No, it is not my intent to make that list long.

The chat auto translate everything to your native or preferred language with the apoppriate letters.

Every message has a notice, which on a tap, it would revert back to its original text;

In case i feel i'll do better than the translator. Or maybe a genuine check.

I played the game like a year just because fascinated by the auto translate. Lul.

Had fun chatting with lads from different countries.

Tho the game itself was 20x10^10^10% not recommended.

 

Back to the box letters.

Some introduced how to fix this maybe 2 years ago, i tried but still no avail.

Like you must change the locale and let the client updates, then swing back to English or your preffered language.

It didn't work.

Shrugs.

 

In an occasion;

I ever ventured just want to know what letter was this boxes. So i played the replay file with a Japanese locale, for starter.

Still boxes.

It turned out to be Korean letters, Hangeul, after a few tries.

Edited by Brunswickz
  • Cool 1

Share this post


Link to post
Share on other sites
2,309
[REPOI]
Member
5,834 posts
24,300 battles
9 minutes ago, Brunswickz said:

I saw this on the Migration thread, it comes to my mind.

Why, after 4 years, this hasn't solved ?

I can't read Chinese, Thai, or Korean but at least i wish the game can show proper letters.

Better, if the game can include auto translate into the chat.

 

A game at android, anime version of z-world can do that. I don't remember the name.

People still having difficulties with the auto translate but it is much better.

My clan were consisted of people typing English, German, Brazilian Portugese, Spanish, South American Spanish, French, Bahasa, Swedish, Chinese and Japan.

No, it is not my intent to make that list long.

The chat auto translate everything to your native or preferred language with the apoppriate letters.

Every message has a notice, which on a tap, it would revert back to its original text;

In case i feel i'll do better than the translator. Or maybe a genuine check.

I played the game like a year just because fascinated by the auto translate. Lul.

Had fun chatting with lads from different countries.

Tho the game itself was 20x10^10^10% not recommended.

 

Back to the box letters.

Some introduced how to fix this maybe 2 years ago, i tried but still no avail.

Like you must change the locale and let the client updates, then swing back to English or your preffered language.

It didn't work.

Shrugs.

 

In an occasion;

I ever ventured just want to know what letter was this boxes. So i played the replay file with a Japanese locale, for starter.

Still boxes.

It turned out to be Korean letters, Hangeul, after a few tries.

the most versatile client in game rn is the trad chinese i think, it displays chinese, english, and japanese, while the others only display the language it's config'd in and then english

  • Cool 1

Share this post


Link to post
Share on other sites
16
[NAU]
Super Tester_
558 posts
7,860 battles

I have had no luck getting the client to show the correct character sets either.

I cant read Chinese/Japanese (some Korean), but I can tell the difference between the character sets. 

My PC is setup to display these character sets, but as soon as I enter the game I lose this functionality?

Its very frustrating.

Share this post


Link to post
Share on other sites
450
[KAMI]
Member
1,368 posts
11,808 battles
23 minutes ago, Black_Ice said:

I have had no luck getting the client to show the correct character sets either.

I cant read Chinese/Japanese (some Korean), but I can tell the difference between the character sets. 

My PC is setup to display these character sets, but as soon as I enter the game I lose this functionality?

Its very frustrating.

try this

if you want english client that enables you to read chinese character

 

i been using this method instead of using mod recently 

<locale_id>en</locale_id>
    <text_path>../res/texts</text_path>
    <text_domain>global</text_domain>
    <!-- acceptLang is comma delimited ordered list of language codes without any whitespace that will be used in the "Accept-Language" HTTP header. -->

    <lang_mapping>
        <lang acceptLang="ru" fonts="RU" full="russian" languageBar="false" localeRfcName="ru" short="ru"/>
        <lang acceptLang="en,zh-Sg" fonts="CN" full="schinese" languageBar="true" localeRfcName="en" short="en"/>
        <lang acceptLang="de,en" fonts="EU" full="german" languageBar="false" localeRfcName="de" short="de"/>
        <lang acceptLang="pl,en" fonts="EU" full="polish" languageBar="false" localeRfcName="pl" short="pl"/>
        <lang acceptLang="fr,en" fonts="EU" full="french" languageBar="false" localeRfcName="fr" short="fr"/>
        <lang acceptLang="es,en" fonts="EU" full="spanish" languageBar="false" localeRfcName="es" short="es"/>
        <lang acceptLang="cs,en" fonts="EU" full="czech" languageBar="false" localeRfcName="cs" short="cs"/>
        <lang acceptLang="tr,en" fonts="EU" full="turkish" languageBar="false" localeRfcName="tr" short="tr"/>
        <lang acceptLang="it,en" fonts="EU" full="italian" languageBar="false" localeRfcName="it" short="it"/>
        <lang acceptLang="ja,en" fonts="ASIA" full="japanese" languageBar="false" localeRfcName="ja" short="ja"/>
        <lang acceptLang="zh-Tw,en" fonts="CN" full="tchinese" languageBar="true" localeRfcName="zh-tw" short="zh_tw"/>
        <lang acceptLang="th,en" fonts="TH" full="thai" languageBar="false" localeRfcName="th" short="th"/>
        <lang acceptLang="ko,en" fonts="KO" full="koreana" languageBar="false" localeRfcName="ko" short="ko"/>
        <lang acceptLang="zh-Sg,en" fonts="CN" full="schinese" languageBar="true" localeRfcName="zh-sg" short="zh_cn"/>
        <lang acceptLang="pt-Br,pt,en" fonts="EU" full="brazilian" languageBar="false" localeRfcName="pt-br" short="pt_br"/>
        <lang acceptLang="uk,ru,en" fonts="RU" full="ukrainian" languageBar="false" localeRfcName="uk" short="uk"/>
        <lang acceptLang="es-Mx,es,en" fonts="EU" full="mexican" languageBar="false" localeRfcName="es-mx" short="es_mx"/>
        <lang acceptLang="be,ru,en" fonts="RU" full="belorussian" languageBar="false" localeRfcName="be" short="be"/>
        <lang acceptLang="nl,en" fonts="EU" full="dutch" languageBar="false" localeRfcName="nl" short="nl"/>
    </lang_mapping>
</locale_config>

 

Edited by Gummilicious
  • Cool 4

Share this post


Link to post
Share on other sites
Member
1,144 posts
4,770 battles
5 hours ago, Gummilicious said:

try this

if you want english client that enables you to read chinese character

 

i been using this method instead of using mod recently 


<locale_id>en</locale_id>
    <text_path>../res/texts</text_path>
    <text_domain>global</text_domain>
    <!-- acceptLang is comma delimited ordered list of language codes without any whitespace that will be used in the "Accept-Language" HTTP header. -->

    <lang_mapping>
        <lang acceptLang="ru" fonts="RU" full="russian" languageBar="false" localeRfcName="ru" short="ru"/>
        <lang acceptLang="en,zh-Sg" fonts="CN" full="schinese" languageBar="true" localeRfcName="en" short="en"/>
        <lang acceptLang="de,en" fonts="EU" full="german" languageBar="false" localeRfcName="de" short="de"/>
        <lang acceptLang="pl,en" fonts="EU" full="polish" languageBar="false" localeRfcName="pl" short="pl"/>
        <lang acceptLang="fr,en" fonts="EU" full="french" languageBar="false" localeRfcName="fr" short="fr"/>
        <lang acceptLang="es,en" fonts="EU" full="spanish" languageBar="false" localeRfcName="es" short="es"/>
        <lang acceptLang="cs,en" fonts="EU" full="czech" languageBar="false" localeRfcName="cs" short="cs"/>
        <lang acceptLang="tr,en" fonts="EU" full="turkish" languageBar="false" localeRfcName="tr" short="tr"/>
        <lang acceptLang="it,en" fonts="EU" full="italian" languageBar="false" localeRfcName="it" short="it"/>
        <lang acceptLang="ja,en" fonts="ASIA" full="japanese" languageBar="false" localeRfcName="ja" short="ja"/>
        <lang acceptLang="zh-Tw,en" fonts="CN" full="tchinese" languageBar="true" localeRfcName="zh-tw" short="zh_tw"/>
        <lang acceptLang="th,en" fonts="TH" full="thai" languageBar="false" localeRfcName="th" short="th"/>
        <lang acceptLang="ko,en" fonts="KO" full="koreana" languageBar="false" localeRfcName="ko" short="ko"/>
        <lang acceptLang="zh-Sg,en" fonts="CN" full="schinese" languageBar="true" localeRfcName="zh-sg" short="zh_cn"/>
        <lang acceptLang="pt-Br,pt,en" fonts="EU" full="brazilian" languageBar="false" localeRfcName="pt-br" short="pt_br"/>
        <lang acceptLang="uk,ru,en" fonts="RU" full="ukrainian" languageBar="false" localeRfcName="uk" short="uk"/>
        <lang acceptLang="es-Mx,es,en" fonts="EU" full="mexican" languageBar="false" localeRfcName="es-mx" short="es_mx"/>
        <lang acceptLang="be,ru,en" fonts="RU" full="belorussian" languageBar="false" localeRfcName="be" short="be"/>
        <lang acceptLang="nl,en" fonts="EU" full="dutch" languageBar="false" localeRfcName="nl" short="nl"/>
    </lang_mapping>
</locale_config>

 

I tried your method just now and it works well (I dislike the half-baked Traditional Chinese version currently available). Now I can read what the other Chinese-speaking players are talking on the channels, except two minor probelms: with the modified XML file (I used zh-CN instead), the space between different words become a bit wider than before which caused some minor problems with the English UI: besides the excessive blank space reminds me of primary school textbooks, it disturbs the original typesetting of the English UI. The other one is that the abbreviated "ou" and "uu" present in a number of Japanese ship names cannot be properly rendered in the font primarily used in-game (and now they look a bit wider than other letters). It works perfectly overall anyway.

The game also seems to be a bit more laggy after the modification.

Edited by Project45_Opytny

Share this post


Link to post
Share on other sites
574
[-CAT-]
Member
1,327 posts
9,626 battles
3 hours ago, Project45_Opytny said:

I tried your method just now and it works well (I dislike the half-baked Traditional Chinese version currently available). Now I can read what the other Chinese-speaking players are talking on the channels, except two minor probelms: with the modified XML file (I used zh-CN instead), the space between different words become a bit wider than before which caused some minor problems with the English UI: besides the excessive blank space reminds me of primary school textbooks, it disturbs the original typesetting of the English UI. The other one is that the abbreviated "ou" and "uu" present in a number of Japanese ship names cannot be properly rendered in the font primarily used in-game (and now they look a bit wider than other letters). It works perfectly overall anyway.

The game also seems to be a bit more laggy after the modification.

I can see 3 chinese language settings set to true. Could you try only setting 1 as true and the other 2 as false? It might be the limitation in WG game engine in language support (?). Can "probably" only set 2 language where latin engish is default.

I can somewhat distingush the 3 characters (CN, KR, JP). Japanese sometimes use full kanji, so both Chinese and Japanese can somewhat understand. (I think some Koreans can understand it too.)

Share this post


Link to post
Share on other sites
32
[STEIN]
Member
128 posts
10,699 battles
        <lang acceptLang="en,zh-Sg" fonts="CN" full="schinese" languageBar="true" localeRfcName="en" short="en"/>

Except this line, i set the other Asian languages as true.

Still doesn't work with default EN locale.

Only works with Chinese locale?

Share this post


Link to post
Share on other sites
574
[-CAT-]
Member
1,327 posts
9,626 battles
4 minutes ago, Brunswickz said:

        <lang acceptLang="en,zh-Sg" fonts="CN" full="schinese" languageBar="true" localeRfcName="en" short="en"/>

Except this line, i set the other Asian languages as true.

Still doesn't work with default EN locale.

Only works with Chinese locale?

I think thats pinyin? Please correct me if I am wrong. Could be some settings needed to fix in the language bar or WG had poor translation.

Edited by S0und_Theif

Share this post


Link to post
Share on other sites
32
[STEIN]
Member
128 posts
10,699 battles

That line isn't there by default, so for starter, i don't want to add a new line.

If required tho, i will.

Share this post


Link to post
Share on other sites
574
[-CAT-]
Member
1,327 posts
9,626 battles
13 minutes ago, Brunswickz said:

That line isn't there by default, so for starter, i don't want to add a new line.

If required tho, i will.

I can understand if you feel uncomfortable editing files. It may or may not break the game.

If you want to test, create a backup of the entire game folder, then edit the file.

If it breaks, delete the edited file and paste the file back. If the game still won't work, delete the game and folder, paste back your back up and reinstall. It will take 30 mins to reinstall if you have back up folder.

 

Of course these are uncertain things dealing with software. They may work well, they may not work well. 

 If really uncomfortable, safest play is leave it as is. :Smile_Default: No harm in trying but safety first and leave it as is.

Sorry if I could not help much.

  • Cool 1

Share this post


Link to post
Share on other sites
450
[KAMI]
Member
1,368 posts
11,808 battles
49 minutes ago, Brunswickz said:

        <lang acceptLang="en,zh-Sg" fonts="CN" full="schinese" languageBar="true" localeRfcName="en" short="en"/>

Except this line, i set the other Asian languages as true.

Still doesn't work with default EN locale.

Only works with Chinese locale?

sorry this my xml file

use zh-Cn instead of zh-SG

Share this post


Link to post
Share on other sites
32
[STEIN]
Member
128 posts
10,699 battles
40 minutes ago, S0und_Theif said:

I can understand if you feel uncomfortable editing files. It may or may not break the game.

If you want to test, create a backup of the entire game folder, then edit the file.

If it breaks, delete the edited file and paste the file back. If the game still won't work, delete the game and folder, paste back your back up and reinstall. It will take 30 mins to reinstall if you have back up folder.

 

Of course these are uncertain things dealing with software. They may work well, they may not work well. 

 If really uncomfortable, safest play is leave it as is. :Smile_Default: No harm in trying but safety first and leave it as is.

Sorry if I could not help much.

Eh? No worries, i zip the original file as backup.

I appreciate any help 🙂

 

19 minutes ago, Gummilicious said:

sorry this my xml file

use zh-Cn instead of zh-SG

Ill try this then, thanks.

  • Cool 1

Share this post


Link to post
Share on other sites
450
[KAMI]
Member
1,368 posts
11,808 battles
1 hour ago, Brunswickz said:

I tried with the whole text. It works!

Sorry for a late reply, i had to play some battles until someone typing Chinese at chat lol.

Thanks for the code @Gummilicious.

Your welcome!

Share this post


Link to post
Share on other sites
1
[CL]
Member
5 posts
14,942 battles

tried this method but cant seem to make it work on 0.9.3. i wonder if using Aslain's mods affects this

Share this post


Link to post
Share on other sites
Sign in to follow this  

×