Jump to content
You need to play a total of 10 battles to post in this section.
GOMBEE8626

WoWS Mac Wrapper Bugs and Feedback Thread

64 comments in this topic

Recommended Posts

Administrator
373 posts

[Update] 08:30 UTC+8, 26th Apr 2019

Due to recent changes of the client, current version of official Mac Wrapper might be  unstable for now. We are working on new version of Mac Wrapper with CodeWeavers in order to improve this.

You can try beta version of Mac Warpper if you suffer some techincal issue with current version.

http://www.mediafire.com/file/xm5lp05859y2cnh/wargaminggamecenter-3.1.0_beta4.dmg/file

Please let us know your feedback as always.

Action Stations!

 


Hello Captains!

 

As some of you may know, WoWS is able to run on Mac using 3rd party program, Mac Wrapper.

First, we would like to remind you that the Mac Wrapper is still in its testing phase.

Therefore we can provide only limited amount of support for the Wrapper and client within at this stage.

 

Spoiler

To download the Wrapper, follow this link: LINK

 

DOWNLOADING WORLD OF WARSHIPS:

 

When you have finished downloading the Wrapper and launch it for the first time, the World of Warships Launcher will pop up and begin to download the game.

Currently this is the only way to install World of Warships onto your Mac. Files are being placed in a specific file system and currently cannot be dropped in.

Once the game client is downloaded, you can log in and play just like Windows World of Warships. You are on the same servers and using the same ships and controls as the Windows client users.

 

 

SUPPORT FOR THE MAC WRAPPER CLIENT:


Right now, all support for the Mac Wrapper will be done through this section of the forum.

Therefore please leave your comments below without any hesitation.

 

Action Stations!
 

Share this post


Link to post
Share on other sites
0
[RAN_]
Member
11 posts
2,428 battles

After a few battles, the game client would quit unexpectedly.  Is this issue has anything to do with the wrapper?

Share this post


Link to post
Share on other sites
25
[DERRO]
Member
88 posts
13,933 battles

can the guys in the world of ships department talk to the guys in the world of tanks department? Cause they don't break the wrapper when doing patches but ships seem to manage it every patch.

Share this post


Link to post
Share on other sites
0
[RAN_]
Member
11 posts
2,428 battles

it is great that the wargaming client is 64-bits but then wrapper (Wine) is still 32 bits.  It's refuse to start the 64-bits program.

Share this post


Link to post
Share on other sites
[-AWN-]
Member
3 posts
2,499 battles

The 0.8.3 update doesn't work at all, doesn't even start, but that is kind of noted above.

Even before this upgrade Random battles basically didn't work at all due to game lockups (sometimes it even managed to lock the whole computer up). Yet, I could use the same ship for hours and hours in co-op. If I were a betting man I would say it was likely that the wrapper doesn't allocate enough memory when it starts and that random battles have more players and so needs more memory, but that is just a guess. Anyway, it takes a LOT longer to get experience and currency up in co-op games than it does in random battles.

My system is a 15" Macbook pro 2.9GHz i7 processor with 16GB ram and 1TB SSD disk. I don't think it is hardware spec related.

Share this post


Link to post
Share on other sites
0
[-ONO-]
Member
1 post
2,278 battles

Doesn't even launch the application past the initial screen. Have the same problem as James, I can't play anything other than Co-op, being Random or Missions, as they lock up after a couple of minutes. Even in Co-op now, if there is a carrier on the team, I'm lucky to get through the full game without the machine freezing.

Share this post


Link to post
Share on other sites
0
[AMPOL]
Member
11 posts
12,382 battles

I too can't launch the game. Until today I had no huge issues (beyond the Narai bug).

Share this post


Link to post
Share on other sites
Member
1 post
527 battles

I too just launched the game it updated and now shows version 0.8.3 on the splash screen and it also wont run for me past the initial splash screen after I click the "Play"
Tried using the Launch in Safe Mode option, but the results are the same.

System: OS X 10.13.6
Hardware: MacBook Pro 2017 15" with Radeon Pro 560 4G and Intel Graphics 630 1536MB.

 

And as reported above in the previous version before todays(?) update I was getting lockups and I'd have to use the force quit key combination to get out of the locked up game and sometimes I had to reboot the laptop using the "vulcan nerve pinch."

EDIT: The installer at the link : http://www.mediafire.com/file/xm5lp05859y2cnh/wargaminggamecenter-3.1.0_beta4.dmg/file from above is working for me.

Edited by chook_on_a_stick

Share this post


Link to post
Share on other sites
0
[AMPOL]
Member
11 posts
12,382 battles

That Mediafire link installs what appears to be a GameCenter for me, but I can't get it to work. After extracting and clicking on "GameCenter.app" I get some Wine HQ Internet Explorer screen and that's it.

Share this post


Link to post
Share on other sites
Member
5 posts
5,385 battles

me too, after latest updated. can't launch the game. even i re-installed that's not working.

Mac OS 10.14.4 Imac (Retina 5K,27-inch,2017), 3.4gHz i5. 16GB DDR4 , Radeon Pro 570 4GB.

Share this post


Link to post
Share on other sites
0
[S_X_S]
[S_X_S]
Member
1 post
3,997 battles

Issues that I have had include:

- All water turning black

- Torpedo tubes aiming indicator and torpedo tubes angles completely disappearing

- Severe glitching in the settings menu

- Continuous crashing out of games which has now caused me to turn orange (REEEEEEEEEE)

EDIT: Still thank you soo much WG for actually attempting to help us Mac OS Users play your game

Edited by 9_9_destroyer
Add additional text

Share this post


Link to post
Share on other sites
Member
12 posts
6,093 battles
On 4/26/2019 at 2:11 PM, James_Winterbottom said:

The 0.8.3 update doesn't work at all, doesn't even start, but that is kind of noted above.

Even before this upgrade Random battles basically didn't work at all due to game lockups (sometimes it even managed to lock the whole computer up). Yet, I could use the same ship for hours and hours in co-op. If I were a betting man I would say it was likely that the wrapper doesn't allocate enough memory when it starts and that random battles have more players and so needs more memory, but that is just a guess. Anyway, it takes a LOT longer to get experience and currency up in co-op games than it does in random battles.

My system is a 15" Macbook pro 2.9GHz i7 processor with 16GB ram and 1TB SSD disk. I don't think it is hardware spec related.

I think I have the same experience with you, the game seems working just fine with coop but not with random battles even lower my graphics settings to lowest. 

I sent an email to CodeWeavers support in earlier days about my freezing problem and they replied to me "Thanks for writing us. The crashes you are describing are most likely due to the application running out of addressable memory, a limitation of 32-bit applications. We're working on a 64-bit update for Wargaming, but until that is released, the best ways to mitigate the crashes are to lower your graphics settings if you haven't already, and to quit/relaunch the game between matches. If you find that you are unable to get through even the first match without crashing, I would try completely removing and reinstalling the game. There are a few hidden files and directories that need to be removed in addition to the game itself, so we've created an uninstall script you can run."

However, even though I reinstalled the game and lower my settings, the game still keeps crashing. And I don't even know where to get the latest information when they release the 64-bit update.

My MacBook is a 2018 15" Macbook pro 

Edited by edwinedwin633

Share this post


Link to post
Share on other sites
WG Staff
511 posts
On 4/26/2019 at 1:11 PM, James_Winterbottom said:

The 0.8.3 update doesn't work at all, doesn't even start, but that is kind of noted above.

Even before this upgrade Random battles basically didn't work at all due to game lockups (sometimes it even managed to lock the whole computer up). Yet, I could use the same ship for hours and hours in co-op. If I were a betting man I would say it was likely that the wrapper doesn't allocate enough memory when it starts and that random battles have more players and so needs more memory, but that is just a guess. Anyway, it takes a LOT longer to get experience and currency up in co-op games than it does in random battles.

My system is a 15" Macbook pro 2.9GHz i7 processor with 16GB ram and 1TB SSD disk. I don't think it is hardware spec related.

 

On 4/26/2019 at 8:09 PM, Laird_V8_noob said:

Doesn't even launch the application past the initial screen. Have the same problem as James, I can't play anything other than Co-op, being Random or Missions, as they lock up after a couple of minutes. Even in Co-op now, if there is a carrier on the team, I'm lucky to get through the full game without the machine freezing.

 

On 4/26/2019 at 8:50 PM, exculcator said:

I too can't launch the game. Until today I had no huge issues (beyond the Narai bug).

 

On 4/27/2019 at 10:05 AM, vivien8888 said:

me too, after latest updated. can't launch the game. even i re-installed that's not working. 

Mac OS 10.14.4 Imac (Retina 5K,27-inch,2017), 3.4gHz i5. 16GB DDR4 , Radeon Pro 570 4GB.

 

On 4/27/2019 at 5:41 PM, edwinedwin633 said:

I think I have the same experience with you, the game seems working just fine with coop but not with random battles even lower my graphics settings to lowest. 

I sent an email to CodeWeavers support in earlier days about my freezing problem and they replied to me "Thanks for writing us. The crashes you are describing are most likely due to the application running out of addressable memory, a limitation of 32-bit applications. We're working on a 64-bit update for Wargaming, but until that is released, the best ways to mitigate the crashes are to lower your graphics settings if you haven't already, and to quit/relaunch the game between matches. If you find that you are unable to get through even the first match without crashing, I would try completely removing and reinstalling the game. There are a few hidden files and directories that need to be removed in addition to the game itself, so we've created an uninstall script you can run."

However, even though I reinstalled the game and lower my settings, the game still keeps crashing. And I don't even know where to get the latest information when they release the 64-bit update.

My MacBook is a 2018 15" Macbook pro 

Can you please confirm that you have trieed with new beta verson as I updated it above?

http://www.mediafire.com/file/xm5lp05859y2cnh/wargaminggamecenter-3.1.0_beta4.dmg/file

Share this post


Link to post
Share on other sites
0
[AMPOL]
Member
11 posts
12,382 battles

Uh, yes I have tried the beta wrapper.  I explicitly stated so in my post at 9:28 on Saturday, so I don't know how you missed it.

It's getting more than frustrating at this point. My paid-for Premium time is being pissed away, and I also can't earn tokens for the current time-limited event...

 

 

Edited by exculcator
typos

Share this post


Link to post
Share on other sites
WG Staff
511 posts
2 minutes ago, exculcator said:

Uh, yes I have tried the wrapper.  I explicitly stated so in my post at 9:28 on Saturady, so I don't know how you missed it.

It's getting more than frustrating at this point. My paid-for Premium time is being pissed away, and I also can't earn tokens for the current time-limited event...

 

 

Sorry for missing that part. I was confused as I was dealing with multiple reports. I will try to find what we can do for you even though this is in still beta stage.

Share this post


Link to post
Share on other sites
Member
12 posts
6,093 battles

I tried the new beta version today, played a 4 vs 4 tier 3 random battle since its early morning. Lucky the game didn't freeze but still have to test how does it perform in high tier 12 vs 12 match.

Share this post


Link to post
Share on other sites
1
[-AWN-]
Member
1 post
4,709 battles

This issue seems to have struck me; currently downloading beta client.

Have also experienced instability issues when playing random.  Tend to happen whenever I play random above tier5, although sometimes tier 5 has issues as well.

MacBook Pro (Retina, 15-inch, Mid 2015)

2.5 GHz Intel Core i7 16 GB 1600 MHz DDR3 10.14.4

Have installed and tested beta client.  Works so far.  Have yet to try playing a game.

Have played a number of tier 5 random games without a crash.  Next step will be a random battle for tier 6.

Have played a tier 7 random battle.  This new agent seems to have fixed the issues I was seeing.

Edited by gnewitt
Update
  • Cool 1

Share this post


Link to post
Share on other sites
Member
2 posts
4,535 battles
On 4/26/2019 at 2:11 PM, James_Winterbottom said:

The 0.8.3 update doesn't work at all, doesn't even start, but that is kind of noted above.

Even before this upgrade Random battles basically didn't work at all due to game lockups (sometimes it even managed to lock the whole computer up). Yet, I could use the same ship for hours and hours in co-op. If I were a betting man I would say it was likely that the wrapper doesn't allocate enough memory when it starts and that random battles have more players and so needs more memory, but that is just a guess. Anyway, it takes a LOT longer to get experience and currency up in co-op games than it does in random battles.

My system is a 15" Macbook pro 2.9GHz i7 processor with 16GB ram and 1TB SSD disk. I don't think it is hardware spec related.

This is exactly what happens to me..I don't play Random at all now..Even playing the scenario battles does the same..It would lock up and force me to re start the computer..

I downloaded the Beta wrap, after the upgrade ,and still cant p;lay..It Won't go passed the initial screen....Gets to 3/4 of the bar and freezes...Not happy.

Share this post


Link to post
Share on other sites
0
[AMPOL]
Member
11 posts
12,382 battles

Update. I new patch (?) or similar for the game just downloaded itself onto my computer.  It still doesn't work 😞

 

For those of you have been able to get the GameCenter beta wrapper to work - what did you do to get it to work?

Share this post


Link to post
Share on other sites
0
[RAN_]
Member
11 posts
2,428 battles

After installing the Game Center, I clicked the small arrow next to the PLAY button and explicitly choose 64-bits game client.  And, I can play for about 4 to 6 random battle before it crashed me out.

Have you guys found that and tried that?

Share this post


Link to post
Share on other sites
0
[AMPOL]
Member
11 posts
12,382 battles

I haven't found that, since I can't get the Game Center to so much as open. (Assuming you are referring to some arrow you see after launching the Game Center...)

 

Share this post


Link to post
Share on other sites
Member
1 post
31 battles

Having the same issue as all others above. Can't even open the game with out it force quitting on me. 

trying beta wrapper now.

Share this post


Link to post
Share on other sites

×