Jump to content
You need to play a total of 10 battles to post in this section.
GreenCatcher

Stuck at the Battle Loading Screen

7 comments in this topic

Recommended Posts

Member
1 post
132 battles

[BAD-ENGLISH]

While i was playing WoW ASIA, I was trying to join a Random Battle Matchmaking... I got a lil' bit annoyed because of the Loading got stuck. I can even see the "Real-time" statistic (How many enemy/ally ships got sunked) in the Loading screen. I have waited for over 3+ Minutes but yet it haven't finished loading. After waiting about 4 minutes the game suddenly freezed. When i try to click (on something), The screen suddenly becomes "Unresponsive/white". It already happened twice today, I (My Ship) have lost several Signals and Upgrades. And, I have never ever experienced this issue before.

Also, I did not installs any mods in the game...

Do you mates have any idea how do i fix this issue?

Screenshot (1159).png

Edited by GreenCatcher
Grammar Edit

Share this post


Link to post
Share on other sites
10
[AUSDF]
Member
30 posts

Good Luck its been like since the last major update, now imagine having an iMac that it happens 15 to 20 times a day and after numerous players have complained and months gone by guess what.... wows still haven't done a dam thing about it nor do they actually care which is why myself and many many others have stopped spending money on a game that dev's can't be bothered fixing

Share this post


Link to post
Share on other sites
2
[TROLL]
Member
28 posts
6,385 battles

Hello

Can someone please help as I just received 6 team kill penalties for outing in battle early and no activity. Well this all due to inability to get into battle or once in battle not having any control/disconnection while in battle

Share this post


Link to post
Share on other sites
124
[SPCTH]
Member
367 posts
7,366 battles

Mine is getting stuck in the loading screen and the timer will go past 6-7 minutes and most likely forever. But if i shut it down from the Task manager and re-load the game fast enough, it loads into the game and sometimes i might be alive most of the time not. It seems like a disconnection on there server end. This only started recently with the new patches and updates.

Share this post


Link to post
Share on other sites
21
[PST]
Modder
70 posts
4,655 battles

this is can come from of several factors,like your hardisk is get some overwrite when u being multitask, your ram is fully from any background running app, some data patch in wows is missing or corrupt, u can check and repair from the WGC client, if that problem is keep exist, u can search for help in player support wows(send ticket

Share this post


Link to post
Share on other sites

×