Jump to content
You need to play a total of 10 battles to post in this section.
Teostra

Wargaming Game Center ruins my laptop, please help

8 comments in this topic

Recommended Posts

Member
298 posts
7,834 battles

so i was having a break from the game after CV reworks because the game was not balanced from the gameplay standpoint (for me at least), but last night i decided to try playing again to see if the game already balanced enough for me to actually enjoy, but i never got past the first loading screen right after you put your id and password, so i exit the game and proceed to check file integrity, and after a while (about 2 hours or so) the progress stop at 86%, i tried it again for the second time and it still stuck at 86%, my friend in facebook told me that the game doesn't support 32 bit anymore to which i replied that shouldn't be a problem because i've always been using 64 bit windows anyway, and i decided to reinstall the game and downloading it from the web, little did i know that would be the worst thing i have ever done to my laptop, 2nd only to when i accidentally infected my laptop with a virus, so here it goes...
i leave my laptop to download the game overnight while i sleep, and when i woke up the launcher has finished downloading the game and curently checking for game integrity at 6%, and i tried to move my cursor, it didn't work, i tried multiple times but it's still not moving, it took me a while to realize that my laptop was freezing because i literally just woke up, i decided to leave it like that for an hour or so but it's still not working, nothing i could do, pressing alt + 4, summon task manager, nothing, so i forcefully shutdown by holding the power button, and then the problem persist again, but now my laptop it's not freezing but it's really really slow i barely can do anything but watch the launcher doint its thing, which still is stuck at 6%, and then it said that it failed to conect to server or something like that, it restart the process automatically and everytime it always stuck at 6%, i leave it for a while but it's not making progress any progress so i decided to uninstall the game from wargaming game center, and guess what happened? my laptop froze again, so i forced to shutdown my laptop again, then i decided to uninstall the WGC and hopefuly maybe redownloading it again from the start, but it literally took me 5+ minutes to open control panel because my laptop runs very slowy, after i succesfully uninstalled the launcher and the game, the launcher said that some folder cannot be deleted have to be deleted manually by me, well i tried to but my laptop still runs very slow and i open task manager to see what's going on, and there it is, wgc.exe is still there in the proccess tab, even though i already uninstalled it, and all this time my HDD light is always on telling me that it's still processing something, my laptop is very slow that maybe it finnaly gave up and told me that explorer.exe has stopped working, and well, my laptop run normal again, my cursor is moving normal again, but i can't restart my laptop, so again i have to manually press the power button to shutdown, and finaly, the wargaming center is gone, the world of warships is gone, my laptop can run smoothly again, no crashing, no freezing, no nothing, eveything back to normal except i can't play the game, i don't know what happened but i know for sure i might not be able to play the game again for god's know how long, even tho i really want to, any help is really apreciated to make wows works again in my laptop, and thank you for reading 

spec 
core i5-2450m
ram 6GB 
nvidia geforce 610m  

Share this post


Link to post
Share on other sites
Member
298 posts
7,834 battles
26 minutes ago, BanditSE1977 said:

Try using this link:

http://dl-wows-gc.wargaming.net/asia/files/Kg9cc1LM/WoWS_internet_install_asia.exe

It is supposed to be a download of the old launcher,not the WGC.

thank you, i'll try it right away

Edited by Teostra

Share this post


Link to post
Share on other sites
246
[TWR]
Member
1,266 posts
4,759 battles

Cool! Let us know if it works.Haven't had confirmation that is actually has the old launcher!

Share this post


Link to post
Share on other sites
Member
298 posts
7,834 battles
8 hours ago, BanditSE1977 said:

Cool! Let us know if it works.Haven't had confirmation that is actually has the old launcher!

unfortunately, it's still not working, the launcher only manage to download the first 5.8gb or so then shows an error while trying to install the game

WoWSLauncher.log

Share this post


Link to post
Share on other sites
246
[TWR]
Member
1,266 posts
4,759 battles

Think I have seen others with that problem,but can't remember if they were able to solve it or not.

Just had a look through a bunch of pages here and on the NA forums,but couldn't find anything recent on that issue.

Share this post


Link to post
Share on other sites
Administrator
373 posts

Hello commander, we are sorry for the inconvenience 😢

If it still happens then could you please send a ticket to our Player support team?

Thank you!

Share this post


Link to post
Share on other sites
246
[TWR]
Member
1,266 posts
4,759 battles
On 3/16/2019 at 10:33 PM, Teostra said:

unfortunately, it's still not working, the launcher only manage to download the first 5.8gb or so then shows an error while trying to install the game

WoWSLauncher.log

Teostra,thought of another you may be able to try, if you have a friend who has the game installed and using the old launcher,plus access to an external hard drive.

If you do,copy your friends complete Warships folder to the external drive,then copy it to your laptop.Expect for having to change the log in details,and adjust in game settings,this should work.

Share this post


Link to post
Share on other sites

×