Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
LordTyphoon

Transaction Error?

6 comments in this topic

Recommended Posts

483
[REPOI]
Super Tester_
1,073 posts
17,924 battles

Anyone else getting this when trying to buy ship/mount flags/mount camo etc.?

 

565574111_WorldofWarships1_01_20192_04_00AM.png.d5e4f28f7dfae800dd953cd54083150c.png

 

Share this post


Link to post
Share on other sites
1,211
[TDA]
[TDA]
Alpha Tester
2,117 posts
7,703 battles

ITS THE Y2K VIRUS !!

just a bit late

  • Funny 1

Share this post


Link to post
Share on other sites
2,094
[REPOI]
Member
5,702 posts
23,933 battles

have your tried inserting your credit card and pulling it out again

  • Funny 3

Share this post


Link to post
Share on other sites
1,801
[SLAVA]
Super Tester_
7,897 posts
8,986 battles
2 hours ago, LordTyphoon said:

Anyone else getting this when trying to buy ship/mount flags/mount camo etc.?

 

565574111_WorldofWarships1_01_20192_04_00AM.png.d5e4f28f7dfae800dd953cd54083150c.png

 

Yes, pretty common on the days I'm having connection issues.

Share this post


Link to post
Share on other sites
81
[-FUN-]
Member
349 posts
5,562 battles
7 hours ago, AntifoulAwl said:

ITS THE Y2K VIRUS !!

just a bit late

This shows your age (and also anyone who understands it lol)

  • Cool 1

Share this post


Link to post
Share on other sites
341
[SEARN]
[SEARN]
Member
845 posts
13,884 battles

I was getting that error yesterday when trying to buy a prem bote from the tech tree that I don't need but was trying to buy anyway. Restarted my client and it was still there, so the error saved me money

Share this post


Link to post
Share on other sites
Sign in to follow this  

×