Jump to content
You need to play a total of 10 battles to post in this section.
Fallen_sakura

Will asia server of wows relocate?

9 comments in this topic

Recommended Posts

Member
2 posts
184 battles

Asia server of WOT has relocated from Singapore to Hong Kong. Why don't WOWS do it? The latency of network connection is too high for the players in Japan and Korea. Maybe there should be multiple servers in Asian Region.

Share this post


Link to post
Share on other sites
Member
294 posts
2,997 battles

Let me put it simple:

Why can't they relocate? Don't fix what isn't broken. WoW's Japanese server works fine and that's coming from someone who is from India i.e farthest asian country from the server, geographically speaking.

Latency too high in Japan and Korea? Impossible, at least not an issue from WG's side. If I from India can get 150ms, there is just no way people sitting that close are having it worse. Talk to your ISP as it sounds more of your ISP's issue than anything else.

Multiple servers? Lets see. We touch 10k population on weekdays and maybe 15k or so on weekends. On average we hover around 5k to 7k most of the week. Yea, no point fracturing an already low pop count. They already tried this in WOT by giving Australians their own server and it's already backfired. Most Australians are still playing on Asian cluster cause the que time is ridiculous over at the kangaroo server.

TL;DR Not happening.

Share this post


Link to post
Share on other sites
[WOWMY]
Member
347 posts
16,870 battles
39 minutes ago, LonerPrime said:

They already tried this in WOT by giving Australians their own server and it's already backfired. Most Australians are still playing on Asian cluster cause the que time is ridiculous over at the kangaroo server.

TL;DR Not happening.

They did that in wot already?! haha I am happy to hear that. Deserve them dont they? :)

Share this post


Link to post
Share on other sites
Member
117 posts
2,665 battles
5 hours ago, LonerPrime said:

Let me put it simple:

Why can't they relocate? Don't fix what isn't broken. WoW's Japanese server works fine and that's coming from someone who is from India i.e farthest asian country from the server, geographically speaking

I thought wows asia server is located in Singapore not Japan?

Share this post


Link to post
Share on other sites
Member
2 posts
184 battles

 

10 小時前,LonerPrime 說:

If I from India can get 150ms, there is just no way people sitting that close are having it worse. Talk to your ISP as it sounds more of your ISP's issue than anything else.

Multiple servers? Lets see. We touch 10k population on weekdays and maybe 15k or so on weekends. On average we hover around 5k to 7k most of the week. Yea, no point fracturing an already low pop count. They already tried this in WOT by giving Australians their own server and it's already backfired. Most Australians are still playing on Asian cluster cause the que time is ridiculous over at the kangaroo server.

I understand that for an Indian player, a server in Singapore is necessary. But for players in Northeast Asia, Singapore's servers are too far to play smoothly. Australian players choose the Singapore server instead of the Australian server because there are too few players on the Australian server. But there are many players in Northeast Asia. Because the contract with Chinese agents expires, Chinese players are also likely to enter the Asian server in large quantities.
Therefore, I think it is necessary to establish a server in Hong Kong.

Edited by Fallen_sakura

Share this post


Link to post
Share on other sites
Member
1,069 posts
3,847 battles

ISP issues will most likely be the cause of latency issues.

I am in Australia and have accounts on the ASIA server for Warships,as well as the NA server.Most of the time I get a better connection to the NA server,even though the ping averages 105 ms to there, with less lag than the ASIA one.

Depending on what is happening with my ISP and the cables to Singapore,the ping to the ASIA server for me can average from anywhere from approx 60 ms to 150 ms ,with it varying around the average value at the time by approx 10 to 20 ms.At the moment its steady but can go bad at any time.Apparently the cables keep going out.

Here on the forums I have chatted with someone who lives not very far away from me,who is with another ISP and they don't get the same issues.

The following threads are from a few years ago,but will give you an idea of what the ISP/cable issues can be

 

 

 

Share this post


Link to post
Share on other sites
[LBAS]
Beta Tester
327 posts
On 8/11/2018 at 5:57 AM, RimauLaut said:

They did that in wot already?! haha I am happy to hear that. Deserve them dont they? :)

Well WG promised them almost a decade ago so it is WG's commitment to give them a server for WoT, the same does not necessarily applies to WoWs.

And I am happy they don't, why spend money on them where 95% of them are stingy whiners after all

Edited by spixys

Share this post


Link to post
Share on other sites
Member
1,028 posts
7,503 battles
On 8/11/2018 at 4:53 AM, Fallen_sakura said:

The latency of network connection is too high for the players in Japan and Korea.

Latency problems in Japan = 5300 km?

 

I’m playing from NZ and no problems = 8400 km.

 

I guess geographic distance and network performance are two very different things.

Share this post


Link to post
Share on other sites

×