Jump to content
You need to play a total of 10 battles to post in this section.
legionary2099

Why does inventory take so long to load

10 comments in this topic

Recommended Posts

[LNA]
Member
1,690 posts
10,538 battles

I know this has been in the game for a long time , and my computer is potato , but do you guys notice that the Inventory where we store stuffs take ridiculously to load and access ?

Its has been quite an eye sore and annoying for me when WoT from the same WG take only clicks to access. I think devs should ask the WoT dev team to help optimize the Inventory thingee.

I mean , WoT's version are miles better in terms of performance even though it might not necessarily best in looks.

Share this post


Link to post
Share on other sites
Member
461 posts
8,505 battles

I believe some aspects of the UI are loading a web browser component that can be problematic and slow. I've seen a cef-browser program start up when these slow elements are activated. I don't think it's a full blown web browser like firefox, but perhaps a portion of one. The slowness is probably due to having to start this external program, and the communication stream between it and the game.

Share this post


Link to post
Share on other sites
Member
1,050 posts
7,700 battles
1 hour ago, legionary2099 said:

the Inventory where we store stuffs take ridiculously to load and access ?

I just tried it, took 3 or 4 seconds from clicking “inventory” until the inventory screen popped up. I have 450 items in my inventory.

 

Considering this is a database query from an overseas server, that’s quite acceptable, I would think.

 

So what do you consider 3 to 4 seconds a “long wait” or does it take much longer on your PC?

 

I think the speed of your local PC doesn’t matter. It’s a simple list downloaded in a fraction of a second. I would think extracting the items from the database on the server end is what takes time.

 

I also think that the inventory is a feature that is used rather rarely, so if it takes 5 seconds, what’s the problem?

Share this post


Link to post
Share on other sites
[LNA]
Member
1,690 posts
10,538 battles
7 hours ago, PeterMoe1963 said:

I just tried it, took 3 or 4 seconds from clicking “inventory” until the inventory screen popped up. I have 450 items in my inventory.

 

Considering this is a database query from an overseas server, that’s quite acceptable, I would think.

 

So what do you consider 3 to 4 seconds a “long wait” or does it take much longer on your PC?

 

I think the speed of your local PC doesn’t matter. It’s a simple list downloaded in a fraction of a second. I would think extracting the items from the database on the server end is what takes time.

 

I also think that the inventory is a feature that is used rather rarely, so if it takes 5 seconds, what’s the problem?

It took ages on mine ( read: 4 mins+) , so i actually have to go outside at a net cafe , run the game to access the inventory , and even then , the game still need atleast 30s+ to access the thing.

It is so slow that i wonder if you really need a high end PC to actually access a needed feature in a reasonable time frame.

Share this post


Link to post
Share on other sites
Member
1,050 posts
7,700 battles
16 hours ago, legionary2099 said:

read: 4 mins+

4 minutes? There has to be a problem with your setup or computer, that is not a question of bad game design.

Again, takes 4 seconds for me on a fairly low spec PC.

Share this post


Link to post
Share on other sites
Member
461 posts
8,505 battles

I've done some reading and I can confirm that it is loading a web browser component to display the inventory (along with a couple of other UI elements). They are using something called chromium embedded framework, which is essentially a part of the chromium web browser embedded into the game.

I've had issues with it as well, I put it down to running the game under wine on linux, but perhaps there is actually a bug that causes it. When it fails badly on my machine it spawns as many processes as it can until it fills both my ram and swap space, obviously this makes my machine unusable slow and generally causes a crash of some kind. Perhaps something similar is happening to you, but presents different symptoms.
 

Share this post


Link to post
Share on other sites
Super Tester
7,704 posts
8,025 battles

It's a damn embedded web browser. As @Sparcie mentioned, in addition, it has to do a lot of extra things, like authenticating your access, loading your massive inventory... a lot of the resources aren't always cached. These makes it longer to load. Infact, its annoying to the point that I never even bother to visit inventory and the news pages.

Share this post


Link to post
Share on other sites
Member
265 posts
4,714 battles

Learnt something new, no wonder it feels like a browser launching. That means the clan page is also a browser page? It is painful lag to scroll in it.

PS: mine also slow 30+ seconds. 

Share this post


Link to post
Share on other sites

×