Jump to content
You need to play a total of 10 battles to post in this section.
_ICESTAR_

WOWS Mac OS X Client Graphics Setting

3 comments in this topic

Recommended Posts

0
[LSCA_]
Member
2 posts
2,272 battles

installed World of Warships Ultra from the official website on a MacBook Pro 2017 with a 15.4-inch display, 2.8GHz Intel i7 7700HQ processor, 16 GB RAM, and Radeon Pro 555 2 GB.

The game client is very likely to freeze when entering battle in "Fullscreen" mode with a suitable resolution (2880 x 1800) even though the general graphics quality is set to "Medium" (about 30fps in the port). Sometimes, no matter which graphics options were selected, the client freeze during the countdown so I had to force quit the app from the desktop or restart the computer by holding the power button. Tonight, I changed the DirectX 9 to DirectX 11 and found there is no more freezing when entering battle in "Fullscreen - Windowed" mode (with a fixed resolution of 1680 x 1050, but I also had encountered freezes at the very end of a co-op battle in "High" general graphics setting.

Thank you very much for spending time reading this, I wish we can eventually figure out the optimum setting of graphics in WOWS.

Share this post


Link to post
Share on other sites
14
[STRAT]
Member
25 posts
4,956 battles

Hi Icestar,

I'm a fellow player who uses a less powerful Macbook. I've been playing for two years on my settings, and the only problem I have is a client crash after 4 games, which I solve by restarting my client after 3-4 games. My graphics settings are quite low, and I would suggest you play around with lowering different settings, and then testing it out in 'Scenario' battles until you get a more stable client.

For the client freeze, I would suggest observing if it happens after ~3-4 battles, or after ~1 hour of client run-time. If the freezes mostly occur in such situations, I would suggest restarting your game client after every 4 games like I do.

My settings:

Spoiler

5ad8719bed473_ScreenShot2018-04-19at6_25_44PM.thumb.png.e458d63b7ba310702d489f712c174e9a.png

My Macbook Pro (2014) Specifications: https://support.apple.com/kb/SP703?locale=en_SG&viewlocale=en_US

Also, I have found that not running any other programs or apps in the background helps with client stability. I try to keep only the game client and Discord (for voice comms) running when I play.

Hope this can help you, and good luck : )

  • Cool 1

Share this post


Link to post
Share on other sites
0
[LSCA_]
Member
2 posts
2,272 battles
2 hours ago, derpcargoship said:

Hi Icestar,

I'm a fellow player who uses a less powerful Macbook. I've been playing for two years on my settings, and the only problem I have is a client crash after 4 games, which I solve by restarting my client after 3-4 games. My graphics settings are quite low, and I would suggest you play around with lowering different settings, and then testing it out in 'Scenario' battles until you get a more stable client.

For the client freeze, I would suggest observing if it happens after ~3-4 battles, or after ~1 hour of client run-time. If the freezes mostly occur in such situations, I would suggest restarting your game client after every 4 games like I do.

My settings:

  Hide contents

5ad8719bed473_ScreenShot2018-04-19at6_25_44PM.thumb.png.e458d63b7ba310702d489f712c174e9a.png

My Macbook Pro (2014) Specifications: https://support.apple.com/kb/SP703?locale=en_SG&viewlocale=en_US

Also, I have found that not running any other programs or apps in the background helps with client stability. I try to keep only the game client and Discord (for voice comms) running when I play.

Hope this can help you, and good luck : )

Thank you for sharing your idea. I played some battles fluently after changing my graphics quality to "Low". One thing I found interesting is that I can not really change Graphics API to "DirectX 11". When I tried to adjust this option, it told me to restart the game for the change to take effect. If I do so, the setting will remain "DirectX 9" after I logged back in; else if I click on "OK", the option will remain unchanged as well.

Share this post


Link to post
Share on other sites

×