Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
aristobuluslam

Mac Crashes

12 comments in this topic

Recommended Posts

Member
2 posts
652 battles

World of Warships crashes every single round on Mac. When I asked Customer Support, they basically told me to go to Apple's support page and I reinstalled it. But when I opened the reinstalled version, it looks like this

 

5a992fa8d0f12_ScreenShot2018-03-01at10_00_20.thumb.png.5cd698dcad92b17a46a3194739f71c63.png:

I tried this 7 or 8 times, it always goes like this. Wargaming, please find a fix on this

Share this post


Link to post
Share on other sites
16
[DERRO]
[DERRO]
Member
74 posts
11,986 battles

try the following and see if they help

 

1. make sure have most current version of launcher and its definitely from the asia website

2. Open launcher, click settings, then support, then do a repair.

3. if using a Nvida graphics card get the vida drivers

4. run the game fullscreen, if your using an external monitor with a MacBook pro, close the lid on the laptop, it helps with your frame rates.

5. the mac should be making sure all apple updates are applied if not, do so.

hope these help

 

 

 

Share this post


Link to post
Share on other sites
Member
45 posts
3,312 battles

I agree, I usually have it freeze after about 5 or 6 battles. Don't know why it would be every game for aristobuluslam. Now I usually quit after 2 or 3 battles and restart.

On 12/24/2018 at 6:48 PM, petercheung128 said:

WOWS for mac is a joke

 

Edited by Pete_the_pirate

Share this post


Link to post
Share on other sites
1
[BTTW]
Member
20 posts

Hey guy's and gal's

Not meaning to hijack the thread "BUT"

I too am having some issues with crashes so I deleted WoWs and reloaded  it, but I only get a NA server logon yet I am usually be on the Asia sever.

Don't matter how I try I can get an Asia logon (yep =- downloaded from asia server)

Are there any guides/ tutorials (ha ha ha ) to give me some ideas

Thanks in advance

Bazz

Share this post


Link to post
Share on other sites
1,898
[TDA]
Super Tester
4,468 posts
5,062 battles
14 minutes ago, bazz1027 said:

Hey guy's and gal's

Not meaning to hijack the thread "BUT"

I too am having some issues with crashes so I deleted WoWs and reloaded  it, but I only get a NA server logon yet I am usually be on the Asia sever.

Don't matter how I try I can get an Asia logon (yep =- downloaded from asia server)

Are there any guides/ tutorials (ha ha ha ) to give me some ideas

Thanks in advance

Bazz

You have downloaded the NA client instead of the Asia client.

https://worldofwarships.asia/en/content/game/

 

If you use WGC then go to the top left and check if you are logged in under a NA or Asia profile.

Edited by RalphTheTheatreCat

Share this post


Link to post
Share on other sites
1
[BTTW]
Member
20 posts

Thanks RalphTTC

Yep, at first I think you are right but since then I have uninstalled and re-downloaded making sure that I did actually download from Asia......

So, is it possible to download NA from Asia server??

cheers

Share this post


Link to post
Share on other sites
1,898
[TDA]
Super Tester
4,468 posts
5,062 battles

The Asia client wont do anything but Asia.  WGC can do both servers.

Share this post


Link to post
Share on other sites
1
[BTTW]
Member
20 posts

Nope!

Something really wrong here, still get an NA server login screen........

Back to the drawing board 😞

Share this post


Link to post
Share on other sites
Sign in to follow this  

×