Jump to content
You need to play a total of 10 battles to post in this section.

8 comments in this topic

Recommended Posts

225
[151ST]
Member
1,013 posts
4,505 battles

So I've raised a ticket, no response yet, however I wanted to open it to the floor.
After a restart yesterday my Warships and PTS, despite booting the launcher on Monitor 1, now boot in monitor 2.
I have tried everything, and only one monitor is appearing in settings.
Windows is fine, nvidia is fine, other games are fine.
Have tried config file deletion, switching windowed modes, etc.

Whenever I got any form of full-screen (including maximising) the game switches screens. To be honest this is game-breaking for me as I have one 'bigger' and one 'smaller' and I do a lot of stuff while gaming (ie discord, youtube, music, etc).

Any ideas folks?

Share this post


Link to post
Share on other sites
225
[151ST]
Member
1,013 posts
4,505 battles

OK
I'm going to keep this post here but after many different attempts to fix it I found a fix.

I entered nvidia control panel and set 2nd monitor to primary and then set 1st back to primary and saved. It has fixed both games.

I tried doing the same through windows display settings yesterday and it didn't work.

Mods: please leave this here so that when someone else has same issue they can find it on google, as I couldn't find anything that was the same when I was trying to fix it.

Share this post


Link to post
Share on other sites
Member
491 posts
7,634 battles
29 minutes ago, S4pp3R said:

I tried doing the same through windows display settings yesterday and it didn't work.

Glad you got it sorted. As a former computer tech something I would often say to customers "Don't trust Microsoft software programming or Windows".

Case in point, yesterday evening get home late from work and boot computer and I leave to go get something and come back to expect to find my desktop on my monitor. Nope. I get the windows repair and restore (Win 7 Pro) screen telling me it cannot fix the issue stopping my computer from booting. Great just what I needed. Restart anyway as I forgot to try a previous restore point to see if that would fix anything, to find Windows boot 100% fine without any errors. WTF Microsoft??? :Smile_facepalm:

The number of times with any version of windows where it would tell me it has fixed a problem, only for it to not have fixed anything. Or tell me it cannot fix it, but on restart the PC boots and works fine. If I had a few dollars for each of these times, I could no doubt have bought a controlling share in Microsoft by now...... not that I would want to though! :Smile_sad:

 

Share this post


Link to post
Share on other sites
225
[151ST]
Member
1,013 posts
4,505 battles
5 minutes ago, HobartAWD said:

Glad you got it sorted. As a former computer tech something I would often say to customers "Don't trust Microsoft software programming or Windows".

Case in point, yesterday evening get home late from work and boot computer and I leave to go get something and come back to expect to find my desktop on my monitor. Nope. I get the windows repair and restore (Win 7 Pro) screen telling me it cannot fix the issue stopping my computer from booting. Great just what I needed. Restart anyway as I forgot to try a previous restore point to see if that would fix anything, to find Windows boot 100% fine without any errors. WTF Microsoft??? :Smile_facepalm:

The number of times with any version of windows where it would tell me it has fixed a problem, only for it to not have fixed anything. Or tell me it cannot fix it, but on restart the PC boots and works fine. If I had a few dollars for each of these times, I could no doubt have bought a controlling share in Microsoft by now...... not that I would want to though! :Smile_sad:

 

Thanks mate! I'm about as tech savvy as is possible without actually being a coder (although can read most code).

I'm the guy who tries everything before contacting tech support, and then has a argument with tech support because I've already done all that - I'm no noob.

In this case, I prioritised the windows side as OS is base, then driver/applications, then software.

I literally did everything except nvidia control panel (I did the same 'fix' in windows display last night for no result).

I actually like windows for the most part, you are spot on however, windows screws things after updates (maybe my PC updated during restart - I wasn't watching).

Share this post


Link to post
Share on other sites
Member
2,221 posts
13,691 battles

This sounds odd, in that wows couldn't see the second monitor in settings. When both monitors are showing switching is easy. So the real problem here is why wasn't the other monitor showing? Out of interest if you open device manager are any of your monitors registered as generic monitor?

Share this post


Link to post
Share on other sites
225
[151ST]
Member
1,013 posts
4,505 battles

My next step if I hadn't got it fixed was to see if there were available monitor drivers, although never ever needed to do that.

Edited by S4pp3R

Share this post


Link to post
Share on other sites
Member
2,221 posts
13,691 battles
30 minutes ago, S4pp3R said:

Both are @keskparane

 

I expect that is the problem. That is why I asked you to look there. You need to load the monitor drivers.

Edited by keskparane

Share this post


Link to post
Share on other sites

×