Jump to content
You need to play a total of 10 battles to post in this section.
Kerbal94

I just received 52 days of premium for no reason?

17 comments in this topic

Recommended Posts

Beta Tester
159 posts
8,919 battles

The game said I got 52 days of premium time,.... but I don't know what happened, apparently 52 days is not an purchase option in store....

QQ截图20171026213614.png

Share this post


Link to post
Share on other sites
Beta Tester
159 posts
8,919 battles
9 minutes ago, LordTyphoon said:

have you done anything saucy with any WarGaming employees lately?

You know too much! I am going to delete this post!:cap_fainting:

damn, can't find delete button.lol

Edited by Kerbal94

Share this post


Link to post
Share on other sites
Beta Tester
823 posts
5,000 battles

I also received 52 days of premium :o

 

All I did was play WoT once like a few days ago, I played WoWP and bought 2 planes..buuut thats on a different account name :/

 

I guess maybe I did some cool stuff on WoWs...bought a Sims...IDK

Share this post


Link to post
Share on other sites
[LLBC]
Super Tester
752 posts
3,393 battles

Just checked and it seems I also received 52 days. just guessing here, but it might be related to WG saying they would credit ANZ WoT players (Ships was never mentioned tho) it back due to the SeaMeWe3 fault

 

edit: found this post over on the WoT forums and the timing seems to matche

http://forum.worldoftanks.asia/index.php?/topic/75609-regional-connectivity-anz/page__st__280__pid__1681376#entry1681376

 

 

Edited by Gunduck
update

Share this post


Link to post
Share on other sites
78
[ANZAC]
Member
340 posts
11,711 battles

54 days for me as well - whats that, about $30 NZ? I'

ll take it :D

Edited by j0e90

Share this post


Link to post
Share on other sites
Beta Tester
159 posts
8,919 battles
13 hours ago, Gunduck said:

Just checked and it seems I also received 52 days. just guessing here, but it might be related to WG saying they would credit ANZ WoT players (Ships was never mentioned tho) it back due to the SeaMeWe3 fault

 

edit: found this post over on the WoT forums and the timing seems to matche

http://forum.worldoftanks.asia/index.php?/topic/75609-regional-connectivity-anz/page__st__280__pid__1681376#entry1681376

 

 

Ok, whatever.. I ll take this freebie.. although I don't have any internet problems..:cap_haloween:

Share this post


Link to post
Share on other sites
[SEARN]
Member
514 posts
8,004 battles

Just logged into WOT to check for myself, and yes I got 50+ days premium time as well. I must admit I had been avoiding the game due to the high ping, but I probably would not have been playing much anyway due to work commitments.

Credit where credit is due. Cable is now fixed and ping is much better. WG stepped up and compensated players, so thank you WG :cap_like:

Share this post


Link to post
Share on other sites

×