Jump to content
You need to play a total of 10 battles to post in this section.
Xplod2064

High Explosive problem

6 comments in this topic

Recommended Posts

Member
45 posts
3,994 battles

So recently since the British bb's got released and I have played from the Iron Duke all the way to the Conqueror which i got on the last day of the conversion bonus just past.

The problem is sometimes when you shoot HE it hits and penetrates but does 0 damage like wtf? how can it not do any damage when clearly it penetrated?? Cutting through armour weakens it so just how??

another problem is with my Conq's 457mm guns it ricochets off paper ships like the Minotaur? even on a broadside shot??

Wargaming whyyyyyyyyyyyyyyyyyyyy :(

 

Share this post


Link to post
Share on other sites
Alpha Tester
6,604 posts
2,477 battles

and here we go again explaining things

 

each part of the ships has something called hit points, so if you keep hitting the same part of the ships with HE, there wont be any more damage to deal to it as that part HP already reach 0

Share this post


Link to post
Share on other sites
Member
45 posts
3,994 battles
4 minutes ago, Harpoon01 said:

and here we go again explaining things

 

each part of the ships has something called hit points, so if you keep hitting the same part of the ships with HE, there wont be any more damage to deal to it as that part HP already reach 0

what if it is a ship that has taken 0 damage to start with?

Share this post


Link to post
Share on other sites
Alpha Tester
6,604 posts
2,477 battles
Just now, Xplod2064 said:

what if it is a ship that has taken 0 damage to start with?

then it has something to do with lag or displacement on the server

 

 

ever heard detonation with 0 hit?

 

and oh yes

FOR EVERYONE HERE WHO WANT TO POINT THE FAULTY OF THE GAME

 

PUT THE REPLAY ON GODAMNIT

Edited by Harpoon01

Share this post


Link to post
Share on other sites
Member
45 posts
3,994 battles
7 minutes ago, Harpoon01 said:

then it has something to do with lag or displacement on the server

 

 

ever heard detonation with 0 hit?

 

and oh yes

FOR EVERYONE HERE WHO WANT TO POINT THE FAULTY OF THE GAME

 

PUT THE REPLAY ON GODAMNIT

well idk I do have replays of it but also yea the servers have increased in ping I used to be 104 now I am 190 to me the whole concept of no damage is silly.

Edited by Xplod2064

Share this post


Link to post
Share on other sites
Senior Moderator
3,837 posts
2,602 battles

2 primary causes for 0 damage penetrating hits with HE:

  • Hitting an external module (guns, torps, AA).
  • Hitting the torpedo bulge.

Because HE shells fuze instantaneously, they don't hit the ship's HP sections, so no HP was lost.

 

Note: Zero damage due to complete saturation by gunfire is extremely rare it'd be like finding a unicorn. You will almost always only see complete saturation happen due to torps hitting bow/stern or due to gunfire in tier 1 ships.

Share this post


Link to post
Share on other sites

×