Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Kamanah

R9 Loot Crate

4 comments in this topic

Recommended Posts

Member
318 posts
6,863 battles

I just won my last match and was issued my R9 crate with the 15 Halloween cammo's, but my last Rank Star to complete R10 never popped up, so i'm still showing R10/3s. Anyone else had this issue, or does it need to refresh and update?

Share this post


Link to post
Share on other sites
Member
455 posts
8,038 battles

DId you maybe play a new ranked match while the first was still going on? Maybe somehow the previous match completed after your last one and dragged you back to r10

Share this post


Link to post
Share on other sites
Beta Tester
605 posts
6,761 battles

There was a bug last season where you would win but not go up a star on the battle end screen, sounds like that's happened to you.  The WG server will have you at the correct rank, your client just won't be showing it.  It may fix itself in a while, you could also try restarting your game.

Share this post


Link to post
Share on other sites
Member
318 posts
6,863 battles
14 hours ago, Adm_Kunkka said:

DId you maybe play a new ranked match while the first was still going on? Maybe somehow the previous match completed after your last one and dragged you back to r10

I was only playing 1 game at a time. Was weird though, but the following game i won and it re-issued me the crate, but because i was already issued them after the prior game i got nothing once hitting 10.

 

Regardless its all sorted now, guess it was just a bug as Moggytwo mentioned.

 

Many thanks for your replies.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×