Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Ryuuoh_DeltaPlus

Bought Dunkerque at the premium shop, but ship didn't appear in my account

11 comments in this topic

Recommended Posts

Member
85 posts
4,525 battles

As the title says, I just bought the Dunkerque at the premium shop using MOL points, but somehow I didn't receive the ship in my account. MOL has a receipt of the purchase, but the WG premium shop site displayed an error or something (didn't get to have a screenshot sadly). 

I already sent a ticket to WG about this, but do you think they can address this? I don't want my money go to waste.

Share this post


Link to post
Share on other sites
Member
556 posts
8,197 battles

 

Well, I didn't. That's why I'm kinda worried right now whether Wargaming will consider this.  

 

 

Might want to check with your bank too. If the transaction happened you'll need to ticket WG about it. If not then he transaction never happened.

Share this post


Link to post
Share on other sites
Member
1,386 posts
8,230 battles

Never close your browser before the shop's confirmation page appears. IIRC it was like a √ with a circle around it and stuff? If you wait until this page appears and close the browser after that, usually you can get your boat almost immediately.

Edited by _Halcyon

Share this post


Link to post
Share on other sites
Member
85 posts
4,525 battles

 

Might want to check with your bank too. If the transaction happened you'll need to ticket WG about it. If not then he transaction never happened.

 

I checked my MOL account, and it did get deducted for Dunkerque's price.

Share this post


Link to post
Share on other sites
Member
37 posts
9,869 battles

Double check you bought in the correct region.

I didn't realise i was in the NA region page when I bought the murmansk a while back.

They will refund you.

Share this post


Link to post
Share on other sites
[SBK]
Member
5 posts
2,481 battles

finally someone got the problem same with me

paid via mol(ops something goes wrong)and poof nothing in acc

i got this happen before but the product was sent to acc

this time my alabama lost in the sea of internet,and the ticket got ingored been 2day half

or she radar die cant revice any massage

hope wg crew was repairing her radar,and get her to my port

Edited by kitsune_teitoku

Share this post


Link to post
Share on other sites
Sign in to follow this  

×