Jump to content
You need to play a total of 10 battles to post in this section.
ethan32

premium disappearing

7 comments in this topic

Recommended Posts

0
[HMAS_]
Member
3 posts
417 battles

hey, i bought the ishizuchi a few weeks ago, i then sold it (from my port) to free up more slots. i launched the game just before and felt like a match in the ishizuchi, i can no longer put it in my port. it says i need to buy it again with doubloons. can someone please help? is it a bug?

Share this post


Link to post
Share on other sites
Member
89 posts
8,257 battles

You bought a ship, then you sold it, and so you have to buy it again.

Where's the problem? Or you expected you could get free credits?

Share this post


Link to post
Share on other sites
Super Tester
989 posts
4,319 battles

Firstly mate, this isnt a Bug report.

 

Secondly, you should ask WG support staff. Going in forums isnt going to help at all. I heard someone did this but never know the outcome. At least you tried. Dont get your hopes up, its a waste that you sold her before. So at least just try. 

 

Have a pleasant weekend mate

Share this post


Link to post
Share on other sites
Super Tester
2,725 posts

>>You bought Ishizuchi

>>You sold it to free up port slot

>>You feel playing it again

>>Buy the ship with doubloon

>>Why do I have to buy again??? Is this bug?

 

Why do I feel this is a bomb joke report? Coz it's April 1st!!

 

Dude..... you remembered your reason, you sold it for free up port slot.

Selling the ship does not mean putting it away in the freezer then taking it out for use later. :facepalm:

 

If you want it back, file ticket to support. You have this called "one-time" chance per year to retrieve sold premium ships within a year. Not sure if this is support in WoWs, but WoT has done it.

Edited by Mingfang47

Share this post


Link to post
Share on other sites

×