Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Troy6813

Slow Ships

12 comments in this topic

Recommended Posts

Member
4 posts
4,380 battles

Can anyone shed some light on why my cruisers that run a 35.5 knots look like they are going at about 25 knots? This is happening now for over 6 weeks, I was fast and able to dodge and weave to survive now I get penned because I appear very slow and it frustrates the hell out of me. I am in Melbourne Australia with ADSL2+ and previously all was good but now I am virtually a sitting duck most times without ship speed??

Appreciate anyone's thoughts????      

Share this post


Link to post
Share on other sites
Member
503 posts
4,176 battles

Can anyone shed some light on why my cruisers that run a 35.5 knots look like they are going at about 25 knots? This is happening now for over 6 weeks, I was fast and able to dodge and weave to survive now I get penned because I appear very slow and it frustrates the hell out of me. I am in Melbourne Australia with ADSL2+ and previously all was good but now I am virtually a sitting duck most times without ship speed??

Appreciate anyone's thoughts????      

 

is your speed at maximum? did you press "s" by accident? were you turning? did you accidentally rammed an ally ? during the time when you feel slow?

Share this post


Link to post
Share on other sites
Senior Moderator
1,129 posts

Can anyone shed some light on why my cruisers that run a 35.5 knots look like they are going at about 25 knots? This is happening now for over 6 weeks, I was fast and able to dodge and weave to survive now I get penned because I appear very slow and it frustrates the hell out of me. I am in Melbourne Australia with ADSL2+ and previously all was good but now I am virtually a sitting duck most times without ship speed??

Appreciate anyone's thoughts????      

 

Did you recently get a new ship that could be slower or less maneuverable?

Share this post


Link to post
Share on other sites
Member
4 posts
4,380 battles

No nothing has changed, same cruisers I have been using for ages, I do understand the turning issues and the normal slow down during this process and the ramming etc???

  

Share this post


Link to post
Share on other sites
Super Tester
1,310 posts

 I am in Melbourne Australia with ADSL2+ and previously all was good but now I am virtually a sitting duck most times without ship speed??

Appreciate anyone's thoughts????      

that's probably the issue..

IIRC, AU has bad ping to asia region recently coz the cable cut in ocean.

Share this post


Link to post
Share on other sites
Member
4 posts
4,380 battles

Ok the cable cut lol and yeah ping and lag is really bad what is IIRC?? Funny i play Armoured Warfare on the North Amercian Server and its great no issue runs well?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×