Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
MarshalYngYoda

Invite code not working

3 comments in this topic

Recommended Posts

Member
11 posts
3,773 battles

Hi,

I was registered to world of warships with an invite i received from a friend. 

The invite clearly stated that i would be entitled to receive 2 premium ships.

After playing for a month now, I've still not got the diana which i was to receive after my first battle.

Also I'm supposed to get the texas after playing my first tier 6 game. I doubt that this will work either.

Please suggest something that can be done or who can i get in touch with.

 

Thanks.

Share this post


Link to post
Share on other sites
Super Tester
1,310 posts

seems like u did something wrong there

the code that i gave to my friend worked just fine

 

how to use invite code from playtogether campaign :

  1. register normally. if u have another invite code from somewhere (like from buying asus product, etc) use it here when registering. those invite code from product will not be usable for registered user
  2. after have registered successfully. DO NOT ENTER ANY GAME/BATTLE.
  3. open the link from playtogether that was given to u by ur friend
  4. accept the invite.
  5. after u sure that u are accepting it properly. go open the game client and enter battle..
  6. u should get ur diana.
  7. and u should get the texas after reaching tier 6

 

Share this post


Link to post
Share on other sites
Member
11 posts
3,773 battles

Thanks for the reply

What i had done was that i opened the link my friend had sent, and registered my account.

I didnt accept the invite as i thought that the link was embedded. 

Its disappointing to know i wont receive the texas.

IS there any way around this?

 

Regards

Share this post


Link to post
Share on other sites
Sign in to follow this  

×