Jump to content
You need to play a total of 10 battles to post in this section.
thankino

bigworld client error plus exception unknown error

8 comments in this topic

Recommended Posts

Member
32 posts
624 battles

I just uninstalled the whole game and cleaned every left over and reinstalled it from scratch.

The client starts, the battle search starts then when I'm entering the battle the game's screen hangs and Windows alerts that there is an error.

I then press Ctrl + Esc to return to desktop and find 2 message windows.

 

I found the same error on the EU forums but not here, they also had similar screenshot but different issues in the log file.

Please check out the attachments.

 

PS: before uninstalling the game I experienced black screen and had to manually reset the computer, same as other users are reporting here: http://forum.worldofwarships.eu/index.php?/topic/24595-big-world-client-has-encountered-an-unhandled-exception

 

I'm not surprised that people are complaining about a known problem and there is no replay from Wargaming nor solution, how stupid is that?

World of Warships error.jpg

World of Warships error2.jpg

WoWSLauncher.txt

python.txt

Edited by thankino

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

Have you run through the full troubleshooting setup pinned on this forum? Three things off the top of my head could be causing this error - Not having DirectX 9.0 up to date (and has to be 9.0), C++ Redistributable not up to date, or possible issue with your graphics drivers (make sure SLI/crossfire is turned off). Check if java's working too.

Share this post


Link to post
Share on other sites
Member
32 posts
624 battles

Have you run through the full troubleshooting setup pinned on this forum? Three things off the top of my head could be causing this error - Not having DirectX 9.0 up to date (and has to be 9.0), C++ Redistributable not up to date, or possible issue with your graphics drivers (make sure SLI/crossfire is turned off). Check if java's working too.

 

The installer gave the ok for DirectX so I had no option to download it, meaning it shouldn't be the problem.

The computer is fully updated and it runs several games with no problem what so ever, and I used to play WoW prior to these major update without problems.

With the previous installation (fully updated) when exiting the game and returning to the desktop resulted in my computer freezing while the screen became black, the only solution was to hard reset the computer.

Regarding the troubleshooting setup I met most of the points and especially I posted the relative logs and screen shots, but it appears that no one has a clear idea on what is the cause AND I understand because Windows' environment has too many unpredictable behaviours.

 

I would like to point out one step in the troubleshooting "8. If the problem persists, open up a ticket with Customer Support" and that is a BIG NO NO NO and a waste of time and an insult to users because no one cares after you sent all details and after 6 months you get a stupid misleading script back, my personal experience!

 

However, I set the game interface to "windowed mode" and the game doesn't crash anymore.

I wonder what beta testers do (not everyone) other than playing with premium ships and shooting with premium ammo rather than troubleshooting the game installation and functionality within windows' environment.

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

It would help if you made less passive-aggressive comments. People here are responding on a voluntary basis. Making (passive-)aggressive comments does not make a conducive environment, and makes it less likely for people to actually want to help. Testers test for bugs that affect a large section of the playerbase, as well as the most commonly reported errors. What you're reporting is a client-side issue, which makes it harder to pin down what exactly is causing the issue since the base game is stable and working fine for the majority of players. 

 

Your python.log indicates a possible issue with the New_Tierra map file. That's the map called Polar. This problem might be caused by a corrupted game file, memory leak issue, or a host of other base factors. The troubleshooting guide is to eliminate as many factors as possible to nail down the issue. The first would be a fresh install of the game or a game integrity verification through the launcher. You've done that, so we'll skip that step. 

 

The problem is that auto-updates tend to update later versions of DirectX, whereas the BigWorld engine that World of Warships runs on requires 9.0c, an older version. Hence, you ought to do a re-download to check if that's causing the issue, instead of assuming there is no problem there. Likewise with C++ redistributables/.net framework. Finally, if it's incapable of running at fullscreen, check your graphics card options once more. Make sure the game is utilizing your graphics card when it launches, and that antialiasing done by your graphics card is switched off. All this is accessed in your graphics card utility. If you post your system specs, we can go deeper into this.

 

Finally, we recommend tickets to customer support because they can troubleshoot a lot better than us. We don't have access to the game code or client actions. They do, and they can better check whether or not the problem is server-side or client-side. They've got a wider suite of tools they call utilize to help nail down the issue.

Share this post


Link to post
Share on other sites
Member
89 posts
6,457 battles

I had the same problem and i fixed it by changing the c++ and a file msvcr110.dll and three more much the same files in system32 thats windows 7 64bit. It toke me weeks to work this out with no help from wargaming.net. Look at the files in your video card dir & if you see mfc110.dll & msvcp110.dll copy to system32 file this helped me . good luck mate I hope it works for you By jeff1969jaie

Share this post


Link to post
Share on other sites
Member
32 posts
624 battles

Finally, we recommend tickets to customer support because they can troubleshoot a lot better than us.

 

That is a waste of time, and it's not only my personal experience.

 

I had the same problem and i fixed it by changing the c++ and a file msvcr110.dll and three more much the same files in system32 thats windows 7 64bit. It toke me weeks to work this out with no help from wargaming.net. Look at the files in your video card dir & if you see mfc110.dll & msvcp110.dll copy to system32 file this helped me . good luck mate I hope it works for you By jeff1969jaie

 

I'm done with troubleshooting because I got a life also there is no help from Wargaming since they DO NOT care about tickets.

My believe is that they have no one paid to do this job so all you get is a misleading standard script after six months since you requested support and by an Indian based telemarketing employee who does this during the spare time..

Share this post


Link to post
Share on other sites
Member
32 posts
624 battles

The problem is that auto-updates tend to update later versions of DirectX, whereas the BigWorld engine that World of Warships runs on requires 9.0c, an older version.

 

Well well well..... we know that this game requires and older version of DirectX but what happens after you fresh launch the client it downloads the game AND tells you that the latest version of DirectX is already installed AND it doesn't give you the option to download and install the proper DirectX version, how stupid is that, very very CLEVER programmers!

 

So I decided to copy the WoW folder to another computer that it's reserved as spare computer.

It just have the necessary drivers and basic software to run the system so that I'm SURE this computer has no problems.

As soon as I launched the executable I got an unspecified error (again LOL) telling something about a .dll file missing.

So after many hours on the web I found out that that missing file is included in an older version of DirectX that the silly and smart client (programmed by human LOL) didn't download because it sees the latest version already installed!

Next step I did was to research on Wargaming forums and guess what MANY people have had the identical issue and he/she was blamed because his/her computer had hardware problems!

I found the web link for the RIGHT DirectX that works for this game and FINALLY I could play it without problems!

 

So why these clever people at Wargaming (and here) know that the game requires an older version of DirectX BUT they don't include an option or instructions in the installer?

Why do you guys blame players when you know your own problems and don't know how to fix them???

Share this post


Link to post
Share on other sites
Senior Moderator
4,798 posts
1,924 battles

<snip>

The problem is that auto-updates tend to update later versions of DirectX, whereas the BigWorld engine that World of Warships runs on requires 9.0c, an older version.

<snip>

 

<snip>

Why do you guys blame players when you know your own problems and don't know how to fix them???

<snip>

 

FYI the requirement for DirectX 9c is listed in the system requirements bit right under the big button you click to download the game from.....

 

8y83fn.png

Share this post


Link to post
Share on other sites

×