Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
yansuki

Ribbon Hit bug?

11 comments in this topic

Recommended Posts

Beta Tester
2,083 posts
5,169 battles

i have games where ribbons says i score a penetrating hit but i deal no damage. and sometimes i score overpen but i still deal significant damage. i though i hit a part of a ship with saturated damage but it turns out that there's a bug with the ribbon itself.

 

Share this post


Link to post
Share on other sites
Super Tester
1,310 posts

happen to me several times.

 

my guess is the penetrating hit is actually hitting some module, like secondary/aa guns. but who knows.. 

 

maybe sum1 with better knowledge can give better explaination

Share this post


Link to post
Share on other sites
Member
331 posts
17,063 battles

I see this frequently and its been there since at least when the detailed information became available.

It even occurs in the first salvo to hit a ship and affects as far as i can tell all shells and bombs. torps are fine by the looks of it.

The problem is you cant seem to predict how or when it will occur so it it is difficult to duplicate. The one thing I have noticed if it affects one particular ship  that you fire on that you hit it will tend to randomly continue to give penetrations but no damage for that ship.

Share this post


Link to post
Share on other sites
Member
266 posts
5,142 battles

I've read in a Q&A that those no damage penetration hits are caused by your shells hitting modules which HP already depleted.

So even if you penetrate, you won't do any damage, and it's intentional. I'm not sure about the massive damage overpen, though.

 

 

  1. From time to time you see penetrations (indicated by the new ribbons) with 0 damage no effect. What is the cause/reason for this and is it a bug or intended?In most cases this would be intended – the most usual case is some module fully eating the damage, so that the ship’s hitpoints do not get affected (destroyed gun turrets, for example). Do not forget that even if some part of ship is knocked out, it usually means a huge piece of metal still in its place.

 

 

Share this post


Link to post
Share on other sites
Beta Tester
2,083 posts
5,169 battles

I've read in a Q&A that those no damage penetration hits are caused by your shells hitting modules which HP already depleted.

So even if you penetrate, you won't do any damage, and it's intentional. I'm not sure about the massive damage overpen, though.

 

 

 

 

  it still happened even though is full HP. there's also those ribbon who only show overpen but you deal tonnes of damage which doesn't add up.

Share this post


Link to post
Share on other sites
Member
266 posts
5,142 battles

 

  it still happened even though is full HP. there's also those ribbon who only show overpen but you deal tonnes of damage which doesn't add up.

 

Hmm, okay... now that's weird, haha. Just a guess, maybe there are some modules that don't affect the ship's main HP even when it's destroyed?

 

If not, then I honestly don't know. Maybe it is indeed a bug... :hmm:

Share this post


Link to post
Share on other sites
Member
205 posts
5,305 battles

This has also been reported earlier in the NA and EU forums. The ribbons are client-side, but the damage indicator is server-side. There is a de-sync of some sort happening. Or the damage model is broken. WG doesn't seem to be in any hurry to fix this.

 

When you think about it, if the damage model is server-side, then the moment you shoot, the damage you do has already been decided by the server calculations. The server is not going to wait to see where the shells land when viewed client-side. What damage you see in your viewer has already been decided by the server even before your shells land.

 

Or that's what I think anyway. Time for tin foil hat, heh.  :trollface:

Share this post


Link to post
Share on other sites
78
[ANZAC]
Member
340 posts
11,481 battles

I had read somewhere that if you over pen a dd from the front, the shot can traverse the ship, scoring multiple over pens from 1 shot.

Share this post


Link to post
Share on other sites
Super Tester
7,534 posts
7,978 battles

This has also been reported earlier in the NA and EU forums. The ribbons are client-side, but the damage indicator is server-side. There is a de-sync of some sort happening. Or the damage model is broken. WG doesn't seem to be in any hurry to fix this.

 

When you think about it, if the damage model is server-side, then the moment you shoot, the damage you do has already been decided by the server calculations. The server is not going to wait to see where the shells land when viewed client-side. What damage you see in your viewer has already been decided by the server even before your shells land.

 

Or that's what I think anyway. Time for tin foil hat, heh.  :trollface:

 

Its ok, not going to throw rocks at you. Cause this seems legit.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×