Jump to content
You need to play a total of 10 battles to post in this section.
__Reol__

The Data from Update service is incorrect

10 comments in this topic

Recommended Posts

Member
4 posts

 

I got this problem since I've got DC 3 times in a row since our ISP sucks balls even I tried the QoS method

and this error pops up, tries to delete all client files and reinstall it and same happens

I checked the firewall and it has no problems on it, and I've disable all security features in avast for awhile

The 3rd Screenshot is fresh install of WoWs Client, and same error happens

any ideas how to fix this, I don't want to waste penny to force rent on shops that I've play even I'm on a tight budget and I'm on a rush of ARP Ashigara event since 5 days left to finish.

PS: I never install mods since OBT

 

 

ClientFirewallFiles

 

Share this post


Link to post
Share on other sites
Member
227 posts
2,651 battles

That's too bad, welp, assuming you're using NA client, cant update using official launcher. you can download these updates using direct download or torrent by this way:

 

Find the WoWSLauncher.log inside WOWs folder: take out the url in the files or use this

 

update.worldofwarships.com/?protocol_ver=4&target=sdcontent&launcher_ver=0.0.0.0&client_ver=0.0.0.0&locale_ver=0.0.0.0&sdcontent_ver=0.0.0.0&lang=en

 

enter the link above using web browser, it return some kind of weird document, copy ALL link with .wgpkg at the end and paste to elsewhere

Ex: http://dl-wows-gc.wargaming.net/na/patches/wows_0.3.22.470_launcher_na.wgpkg

you need to download all this later

 

See bold text? It can be replaced with: client, locale, sdcontent and launcher. 4 parts that need to be update.

Repeat the step above to get all the link you need to download.

 

After download all these links, move them to Update folder inside WOWs folder. turn the launcher on and let itself update.

Edited by YetAnotherNoob

Share this post


Link to post
Share on other sites
Member
227 posts
2,651 battles

I am using a Mac and am having the same problem. "The data obtained from the update service is incorrect" 

Can someone please help me? Thank you!

^ use those steps above

 

Especial this:

 Find the WoWSLauncher.log inside WOWs folder

 

 

Share this post


Link to post
Share on other sites
Member
227 posts
2,651 battles

because it request content rather than sdcontent as my client state

 

use this link: update.worldofwarships.asia/?protocol_ver=4&target=sdcontent&launcher_ver=0.0.0.0&client_ver=0.0.0.0&locale_ver=0.0.0.0&sdcontent_ver=0.0.0.0&lang=en and download all .wgpkg file mentioned to Update folder inside WOWS folder

 

modify the WoWSLauncher.cfg, find the line start with <content_ver> and change the wrap tag into <sdcontent_ver>

 

 <sdcontent_ver>0.0.0.0</sdcontent_ver>

 

Save that file and start the launcher.

 

Edited by YetAnotherNoob

Share this post


Link to post
Share on other sites
Member
8 posts
197 battles

because it request content rather than sdcontent as my client state

 

use this link: update.worldofwarships.asia/?protocol_ver=4&target=sdcontent&launcher_ver=0.0.0.0&client_ver=0.0.0.0&locale_ver=0.0.0.0&sdcontent_ver=0.0.0.0&lang=en and download all .wgpkg file mentioned to Update folder inside WOWS folder

 

modify the WoWSLauncher.cfg, find the line start with <content_ver> and change the wrap tag into <sdcontent_ver>

 

 

Save that file and start the launcher.

 

 

Sorry man, I tried but it is not working. I dont think I am doing it correctly. Are there any other ways?

Share this post


Link to post
Share on other sites

×