Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
LittleMusket

World of Warships crashes the graphics card after closing the game

4 comments in this topic

Recommended Posts

Member
14 posts
2,390 battles
I'm posting this on the behalf of anyone else who might run into this problem.
 
Description:
It Basically as the problem states, I can normally exit the game with no effect on my computer. But there are sometimes when I exit the game you get the usual black screen but it stays a bit and then puts a grey screen. That happens really quickly then I get my desktop again and but all the programs and files I had open with my game are gone - like I had shut down and restarted.
 
Current Status:
I've had this for about 1 week I'd say from now (25th July 2016), I have updated my graphics card with a clean install and the problem hasn't occurred yet.
 
What happens afterwards is that your graphics card will no longer function properly, even though the screen is rendering in my native resolution (1080p). So you need to restart the graphics card (restarting the computer, disabling graphics card/the service for the graphics card - I just restart computer then check if is working though 'Device Manager' - if its not then restart again or disable/enable the graphics card in device manager, it should be functioning again.
 
I've only had this problem only with world of warships so far and that why I am posting here.
 
Issue:  'As described above'

Screenshots: None, see description
Ship: -
Map: -
Occurrences:  On Occasion. Reopen the game 2nd or 3rd time, or even for the first time.
Tested: Have a couple of Google Chrome Tabs up, some Office programs, and Text Editors or Spotify and run the game.
Severity: Since it occurs when I close the game it has minimal effect the actual gameplay, but is really annoying to occur at random.
Details:  'As described above'

 

System: Windows 10, Intel i5-4760, NVIDIA GTX 970, 8GB RAM

 

o7

 

 

 
Edited by LittleMusket

Share this post


Link to post
Share on other sites
Beta Tester
2,083 posts
5,169 battles

did you update your graphics card driver?

as for me i'm using old driver because it works fine already and i heard that newer drivers are experiencing problem with the game.

Share this post


Link to post
Share on other sites
Member
14 posts
2,390 battles

did you update your graphics card driver?
as for me i'm using old driver because it works fine already and i heard that newer drivers are experiencing problem with the game.

 

Yeah, I did. I had the 368.22 NVIDIA driver and updated 368.81, its still 368.xx so I could classify it both are the latest drivers.

Currently, the problem still remains after updating the driver ... so the driver may not be the cause.

What I might to is uninstall mods and see if it changes things.

 

Will let you Know, ty :)

 

Share this post


Link to post
Share on other sites
Member
14 posts
2,390 battles

 

I believe I have solved the problem.

 

It after testing, the problem is caused by one the mods I installed from aslain, not sure which one for certain though, but now it doesn't crash after opening and exiting the game several times then.

I'll see if can find out which one it is and post my findings.

 

o7

 

 

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×