Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
maximilianyuen

Wargaming support is very unresponsive and NOT helpful.

11 comments in this topic

Recommended Posts

Member
6 posts
69 battles

So I am a long term paying player in WoT and just started actually playing asian WoS two months ago(was reaching tier 7 in Europe server since WoS beta), bought Warspite and some credit to support dev (multiple purchase on pc and ps4 WoT as well if that matter).

But then their update last month make me not able to login, because I have a notorious drop-down menu disappear in multi-monitor setup. And since the update for some unknown reason need me to select the only option of Asia server before login, meaning I can't login because I can't select that.

I did all thing I possibly can to solve it, down to even unplug all extra LCD into single LCD setup but still exist. Googling solution that like Nvidia surround, play in window mode and all are not helpful.

 

I file a ticket on April 26, got a standard reply on 28 asking for dxdiag( which I have support already in previous ticket on same issue that close down because he think no dropdown option in setting screen only in previous update is not game affecting???).
Give everything he asked on 30, then only receive reply on May 09 on solution that's quite obvious irrelevant in display card setting but let him know it's not working on May 13. No reply until May 21 giving my BS that they will investigate.

This is the worst customer service I have experience so far. Bought a ship that's not cheap at all, and for 2 months and counting I still have no way to just even login the game. On warframe even if they can't help they will tell you what had they tried and why its not work and not leave you hanging. On Elite Dangerous support, they are the most willing to refund dev I ever see. Also reply within 24 hours. Amazing.

If the support of Wargaming is a bit more willing to help, I am expecting some command option to skip the login server select, or get a special launcher that help me pre-select Asia server to get me at least into the game before they fix this simple problem, which WoT under the same wargaming company has no issue of.

If I am not getting a fix or the support continue to ignore, I think it's very reasonable to ask for a refund of all the ships/credit that I purchase?

 

Attached is the support ticket screenshot.

Edited by maximilianyuen

Share this post


Link to post
Share on other sites
Member
2,579 posts
6,713 battles

Can you log in using other computer or laptop? To see if the problem is on your device or on your account

 

I really hope your problem solved so you can enjoy this game with other player...

 

 

Share this post


Link to post
Share on other sites
Member
6 posts
69 battles

thanks, and unfortunately no other PC at hand, unless there is a mac version? but my PC is fully capable of VR and Elite Dangerous and even WoT no problem, pretty sure problem is not on my end. 980 ti, i7 6700k 32G ram, should be good enough to handle a few drop down menu I guess.

 

I am trying very hard to be understanding, but I really can't help Wargaming make any excuse for this really basic simple bug that's critical enough to stop me from login.

Edited by maximilianyuen

Share this post


Link to post
Share on other sites
Senior Moderator
1,129 posts

thanks, and unfortunately no other PC at hand, unless there is a mac version? but my PC is fully capable of VR and Elite Dangerous and even WoT no problem, pretty sure problem is not on my end. 980 ti, i7 6700k 32G ram, should be good enough to handle a few drop down menu I guess.

 

I am trying very hard to be understanding, but I really can't help Wargaming make any excuse for this really basic simple bug that's critical enough to stop me from login.

 

World of Warships for MAC OS X

http://worldofwarships.asia/en/news/announcements/wows-mac-wrapper/

 

Please note that the wrapper from CodeWeavers is currently still in testing. There may still be some issues with the wrapper.
If you face any bugs, please report them to forum.

Edited by ADM_dude

Share this post


Link to post
Share on other sites
Member
2,579 posts
6,713 battles

i see, this bug really annoying.

you already try re instal the game with same result right?

Share this post


Link to post
Share on other sites
Member
6 posts
69 battles

I don't really think the problem is on my side, having already go through all these with the Support's standard procedure.

Now that they know my problem is not a standard one that I can solve by goolging, I just need them to really think of a solution on my otherwise perfectly fine computer.

 

All they need to do is perhaps, just give me a launch command or config that already pre-selected the Asia server. I can live with not able to change any setting in the option. 

 

Instead they just do nothing, not even replying. 

Share this post


Link to post
Share on other sites
Member
6 posts
69 battles

Try deleting your preference.xml file and restart the launcher. That should kick you back to the default window screen

 

Thanks, but that was the first few thing I try, on top of playing in window mode, disabling Nvidia surround, unplugging additional monitor. All tried after restart.

Share this post


Link to post
Share on other sites
Super Tester
1,310 posts

are u playing only at EU server?

if yes.

isn't it better if u reinstalled the client with the real EU client


well duh. sorry if my advice is not so good.

but that's all i can say. since i dont really know about this problem

Share this post


Link to post
Share on other sites
Member
6 posts
69 battles

are u playing only at EU server?

if yes.

isn't it better if u reinstalled the client with the real EU client


well duh. sorry if my advice is not so good.

but that's all i can say. since i dont really know about this problem

 

No, I stop playing EU and only play in Asia. Friend are in Asia server.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×