Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Arch_Admiral_Hood

Can anyone explain this?

19 comments in this topic

Recommended Posts

Member
24 posts
8,199 battles

I was driving T5 Omaha in a T7 match.....
Took a crap ton of damage from the Enemy Independence's Torpedo Bombers and Dive Bombers....

I extinguished all Fires, ate 1 torpedo and dodged the rest

Left with 2k Health and survived it but then suddenly *Poof* I went to 0 Health and Died....

 

Can Anyone Explain this?

P.s. I have extinguished all fires and floods

Share this post


Link to post
Share on other sites
Member
753 posts
8,965 battles

I have experienced this sometimes where you think that you have avoided being killed yet a few moments later BANG you are dead with no visible shots fired and not just with CV's, the only explanation I have for it is lag but I cannot confirm this. 

Share this post


Link to post
Share on other sites
Member
24 posts
8,199 battles

I have experienced this sometimes where you think that you have avoided being killed yet a few moments later BANG you are dead with no visible shots fired and not just with CV's, the only explanation I have for it is lag but I cannot confirm this. 

 

If its lag I understand, but the issue is I wasn't lagging and no other enemy ships were in the area as well....

Share this post


Link to post
Share on other sites
Member
1,923 posts
4,018 battles

 

If its lag I understand, but the issue is I wasn't lagging and no other enemy ships were in the area as well....

 

If this is a bug or glitch you are free to send a ticket to the support along with a valid replay video or screenshot so they can verify and answer it for you. 

Share this post


Link to post
Share on other sites
Member
580 posts
1,587 battles

I was driving T5 Omaha in a T7 match.....

Took a crap ton of damage from the Enemy Independence's Torpedo Bombers and Dive Bombers....

I extinguished all Fires, ate 1 torpedo and dodged the rest

Left with 2k Health and survived it but then suddenly *Poof* I went to 0 Health and Died....

 

Can Anyone Explain this?

P.s. I have extinguished all fires and floods

 

Are you sure you put them all out properly? Maybe an errant cinder made it to the Magazine and "Poof!" went your boat :teethhappy:

 

Honestly, I think so too it might've been lag... Did it mention who exactly destroyed you??

Share this post


Link to post
Share on other sites
Beta Tester
1,043 posts
4,300 battles

I was driving T5 Omaha in a T7 match.....

Took a crap ton of damage from the Enemy Independence's Torpedo Bombers and Dive Bombers....

I extinguished all Fires, ate 1 torpedo and dodged the rest

Left with 2k Health and survived it but then suddenly *Poof* I went to 0 Health and Died....

 

Can Anyone Explain this?

P.s. I have extinguished all fires and floods

 

i'm 100% sure you didnt see it, but a dive bomber killed you.

Share this post


Link to post
Share on other sites
Alpha Tester
6,604 posts
2,477 battles

De-sync problem?

it is kinda fishy too with me having 3000 hp in destroyer then suddenly boom, no bomber nearby and I haven't get detected

Share this post


Link to post
Share on other sites
Member
211 posts
9,931 battles

De-sync problem?

it is kinda fishy too with me having 3000 hp in destroyer then suddenly boom, no bomber nearby and I haven't get detected

 

Yeah De-sync,

When AU suffered bad LAG getting hit by ghost Torpedo's and watching shells fly through ships were pretty common. 

Share this post


Link to post
Share on other sites
Member
783 posts
4,819 battles

 

i'm 100% sure you didnt see it, but a dive bomber killed you.

 

Agree with you there, it's most likely a dive bomber if you just went "poof!". It's pretty hard to notice if the bomber is directly overhead too.

Share this post


Link to post
Share on other sites
Beta Tester
605 posts
6,764 battles

When you use damage control on fires and floods, it always seems to do one more tick after you hit the button. So say it ticks damage, then you hit DC, the fires and flooding disappears, and then it does one more tick.  If you were flooding and had multiple fires, that last tick could easily have killed you.

Share this post


Link to post
Share on other sites
Super Tester
989 posts
4,319 battles

I think its desync.. cause i experienced that wiht my ibuki. 1 torps from shimakaze and my hp was like 3k then i use repair but poof. Nowadays server like too damn high in ping

Share this post


Link to post
Share on other sites
0
[RANZN]
Member
32 posts
2,128 battles

It's happened to me too see shells falling well short but still hitting it has something to do with lag or other program memory/ CPU usage as other (in there own way) programs are under way. Found best to close down game and restart if his happens.

Share this post


Link to post
Share on other sites
Beta Tester
902 posts
4,263 battles

There is always one more bit of damage after repair party, also maybe the lag was for just that moment or milisecond, from what I see, multipule fire and flooding, one more tick can easily kill you.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×