Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
SgtPepper557

My Ship Camera Freezes but game continues

3 comments in this topic

Recommended Posts

Member
5 posts
2,027 battles

Over the last few days randomly throughout battles my ship camera will freeze(sometimes instantly sometimes halfway through the match). If I have zoomed into my scope then the screen freezes. If im viewing my ship then my camera fixes position and my ship will continue to sail off the screen. I can still fire / aim and move my ship however my camera will not move from the position where the error occurs. This makes the game unplayable. When quiting back to the menu no ships will load without fully quiting the application and re starting WOW.

 

Average FPS during a battle 80fps @ ultra settings. Has never dipped below 70

Ping 107ms

I have used the ping test software provided in the pinned lag topic. No issues bar a slight higher hop, being hop 14: i-0-0-0-4.istt04.bi.telstraglobal.net which sits at 207ms

Has anybody else experienced this recently. Really frustrating as im losing my hard earned credits from all my lost matches

 

Share this post


Link to post
Share on other sites
Member
5 posts
2,027 battles

Switch to map, then back to ship (should reset the camera for you)

This is an old bug I have not seen in awhile.

 

wont let me switch to map audio still plays in the background

Share this post


Link to post
Share on other sites
Sign in to follow this  

×