Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
General_Pita

Screen flicker

6 comments in this topic

Recommended Posts

Member
27 posts
2,986 battles

Getting screen flicker in port and game play.. My ship seems semi transparent..can see waves through hull of ship...No mods...GTX690 GCard..latest drivers..Never had this problem with any other versions.

 

Game not playable..All other screens are Ok. Have changed aspect ratio back and forth..no difference..have selected vertical synch ..no difference.. frustrating.

Share this post


Link to post
Share on other sites
Member
1 post
101 battles

I have had the same prob, at the moment I am uninstalling the game and reinstalling it. I am running a intel i7 6700k with 32 gig Ram, and 2 GTX 980Ti with SLI bridge. this should not be happening on my computer.

Edited by SilverDX

Share this post


Link to post
Share on other sites
Member
27 posts
2,986 battles

Was hoping to see a fix for screen flicker in the latest patch...no luck..another day of not playing ...wonder if its a problem with Nvidia cards? My pc is an Alienware Area51 i7 9600 3.2ghz, 24 gb ram, GTX 690(680x2gcpu on the one card)...I usually see around 70fps and 100+ms (Australia, damaged cable from Perth to Singapore)..ive noticed in youtube replays that guys are getting around 100fps -30ms on NA and EU server! But during play my fps will go down to around 20(fluctuates a lot). Hope they fix this screen flicker soon....Like you SilverDX, this should not be happening on our computers!

Edited by mickg

Share this post


Link to post
Share on other sites
Member
27 posts
2,986 battles

After a bit of research, I've discovered that wowarships has issues with SLI cards. As I said, mine is a GTX690, ie 2x680 chips on the one card, so effectively SLI..funny how it caused no problems in previous versions...again, quite a few issues with the gtx 690's so will try to have game use just one CPU and report back with observations..

 

Take 2.. I can report using jut one gpu on the GTX690 does indeed work! No flickering ..All good...No less fps either. 

Open NVIDIA Control Panel

Select Manage 3D Settings

Select Program Settings

Select a program to customize

World Of Warships should be selected(if not, select it)

Find Multi-GPU rendering mode, right click, select Single-GPU

All done!  Enjoy flicker free game!

 

 

Edited by mickg

Share this post


Link to post
Share on other sites
[LBFM]
Member
20 posts
11,371 battles

I've got the same comp as you silver, and it is frustrating as hell going from 4k back to FHD. There definitely is a drop in fps - I used to sit around 70-80 @1440, now it sits at 30 @1080. Vsync is off also.

 

It's been stated that SLI isn't an issue for WG to fix, but it used to work before this update. So why would it be difficult to have the option again?

Share this post


Link to post
Share on other sites
Member
121 posts

After a bit of research, I've discovered that wowarships has issues with SLI cards. As I said, mine is a GTX690, ie 2x680 chips on the one card, so effectively SLI..funny how it caused no problems in previous versions...again, quite a few issues with the gtx 690's so will try to have game use just one CPU and report back with observations..

 

Take 2.. I can report using jut one gpu on the GTX690 does indeed work! No flickering ..All good...No less fps either. 

Open NVIDIA Control Panel

Select Manage 3D Settings

Select Program Settings

Select a program to customize

World Of Warships should be selected(if not, select it)

Find Multi-GPU rendering mode, right click, select Single-GPU

All done!  Enjoy flicker free game!

 

 

 

thanks senior for the hint

now i can play this in mac

Share this post


Link to post
Share on other sites
Sign in to follow this  

×