Jump to content
You need to play a total of 10 battles to post in this section.
spider4929

Crashing because of Fuso?

5 comments in this topic

Recommended Posts

Member
33 posts
2,895 battles

 

Issue:   Game crashes when I interact or look at the Fuso.

Screenshots: None
Ship: Fuso
Map: Any
Occurrences:  Random
Tested: Yes, zoom in/spectate/fight etc. a Fuso.
Severity: Heavy Impact on my gameplay
Details:  The game crashing for some unknown reason is no stranger to me and is negligible but this crashing with an oddly specific reason is kind of impacting my gameplay. Whenever I zoom in on an allied/enemy Fuso at >4 km, fight with a Fuso at close range (i.e. torping a Fuso at close ranges), spectate a friendly Fuso, etc., my game crashes. This crash is really impacting my gameplay because due to this problem, I can't fight a Fuso properly due to the fear of crashing. I can't even help out friendly Fusos fearing they might cause the game to crash. Can anyone please help me solve this?

 

Share this post


Link to post
Share on other sites
Member
724 posts
2,166 battles

Issue:   Game crashes when I interact or look at the Fuso.

Screenshots: None
Ship: Fuso
Map: Any
Occurrences:  Random
Tested: Yes, zoom in/spectate/fight etc. a Fuso.
Severity: Heavy Impact on my gameplay
Details:  The game crashing for some unknown reason is no stranger to me and is negligible but this crashing with an oddly specific reason is kind of impacting my gameplay. Whenever I zoom in on an allied/enemy Fuso at >4 km, fight with a Fuso at close range (i.e. torping a Fuso at close ranges), spectate a friendly Fuso, etc., my game crashes. This crash is really impacting my gameplay because due to this problem, I can't fight a Fuso properly due to the fear of crashing. I can't even help out friendly Fusos fearing they might cause the game to crash. Can anyone please help me solve this?

 

Do you have any mods? Check the 0.5.2.3 folder under res_mods from World of Warships installation directory. 

If there's anything else other than a readme.txt inside, delete it.

Share this post


Link to post
Share on other sites
Super Tester
1,310 posts

if u got any mods installed. try to remove it.

if u dont have mods installed but still crashing, probably a corrupted data taht corresponding with fuso ship.

u might as well try to copy that data from a clean (error free client) from some1.  (try asking sum1 that has good upload speed nicely)

should be in "\World_of_Warships\res\content\gameplay\japan\ship\battleship\" folder 

 

if u got neighbors that also play this game. try to copy his/her full client. this game doesnt need to be installed.

as long as u got necessary runtime installed(direct X, C++, etc). just copy and paste game client will suffice. (since u already installed and running this game. we can assume that u have already got every runtime needed in ur computer. so only copy paste-ing client will do)

Share this post


Link to post
Share on other sites
Member
33 posts
2,895 battles

UPDATE: I don't personally know anyone who play this game so I can't copy the game files.

Also I narrowed down the problem to the 1943 hull of the Fuso. (Hull B & C in-game). I think I need the folder "JSB006_Fuso_1943" in "res\content\gameplay\japan\ship\battleship" folder. If anyone has a clean data of the Fuso 1943 folder (which is only 10 MB), please, PLEASE upload it. I can't play my Fuso because of this.

Edited by spider4929

Share this post


Link to post
Share on other sites
Member
33 posts
2,895 battles

Looks like copying and pasting clean data on the folder didn't work. The game still crashes.

EDIT: Searched the python.log and this showed up:

 

[2016_02_06 17:38:06] [scaleform] Error: Missing font "$Arial" in "". Search log:
   Searching for font: "$Arial" 
      Movie resource: "$Arial"  not found.
      Imports       : "$Arial"  not found.
      Exported      : "$Arial"  not found.
      Registered fonts: "$Arial" not found.
      Searching FontLib: "$Arial"  not found.
      Searching FontProvider: "$Arial"  not found.
   Font not found.

[2016_02_06 17:38:06] ping&FPS: 0.117292355214 1021.93060382 583.930648642 0
[2016_02_06 17:38:06] ping&FPS: 0.117292355214 1021.93060382 1021.93060382 0
[2016_02_06 17:38:06] [DEBUG] (24393018937183232, 151): ExternalInterfaceCallback "battle.setGuiState" not found ((0, True, True, False),)
[2016_02_06 17:38:06] [DEBUG] (24393018937183232, 161): <gui.Scaleform.Flash.Flash object at 0x133D7190>
[2016_02_06 17:38:06] [DEBUG] (24393018937183232, 151): ExternalInterfaceCallback "battle.setGuiState" not found ((0, True, True, False),)
[2016_02_06 17:38:06] [DEBUG] (24393018937183232, 161): <gui.Scaleform.Flash.Flash object at 0x133D7190>
[2016_02_06 17:38:06] WindowsManager.__instanceWindow:  Battle gui.Scaleform.Battle <module 'gui.Scaleform.Battle' from 'C:\Games\World_of_Warships\res\scripts\client\gui\Scaleform\Battle.pyc'>
[2016_02_06 17:38:07] ("[ERROR] FeedbackController: config {event: 'Sound', container: 'screenplay_trigger'} must set 'type'",)
[2016_02_06 17:38:10] ping&FPS: 0.106615449701 3612.9305199 1021.93060382 0
[2016_02_06 17:38:10] ping&FPS: 0.106615449701 3612.9305199 3612.9305199 0
[2016_02_06 17:38:14] ping&FPS: 0.136229361807 3710.93048556 3612.9305199 0
[2016_02_06 17:38:14] ping&FPS: 0.136229361807 3710.93048556 3710.93048556 0
[2016_02_06 17:38:14] [Message]Vehicle::activateOfflineLogic() [True, False, False]
[2016_02_06 17:38:14] ping&FPS: 0.124169092093 652.930482703 3710.93048556 0
[2016_02_06 17:38:14] ping&FPS: 0.124169092093 652.930482703 652.930482703 0
[2016_02_06 17:38:14] ping&FPS: 0.117317031537 255.930481824 652.930482703 0
[2016_02_06 17:38:14] ping&FPS: 0.117317031537 255.930481824 255.930481824 0
[2016_02_06 17:38:15] ping&FPS: 0.123396168862 337.930486935 255.930481824 0
[2016_02_06 17:38:15] ping&FPS: 0.123396168862 337.930486935 337.930486935 0
[2016_02_06 17:38:15] ping&FPS: 0.139827485595 313.930486249 337.930486935 0
[2016_02_06 17:38:15] ping&FPS: 0.139827485595 313.930486249 313.930486249 0
[2016_02_06 17:38:15] ping&FPS: 0.148026059781 344.930485057 313.930486249 0
[2016_02_06 17:38:15] ping&FPS: 0.148026059781 344.930485057 344.930485057 0


Crashed!!!

This is the content of the CRASH file:

 

Application C:/Games/World_of_Warships/worldofwarships.exe crashed 02.06.2016 at 17:38:16


Message:
The BigWorld Client has encountered an unhandled exception and must close (EXCEPTION_ACCESS_VIOLATION : 0xC0000005 @ 0x01513BB0) (Read @ 0x00000098)


System info:
    
OS Name: Windows 7
    
OS Version: 6.6 
    
OS Architecture: x86

 

Memory info:
    
Virtual memory: 1110112Kb/2097024Kb (53%)
    
Working set (process physical memory): 708128Kb/2097024Kb (33%)
    
Commit charge (working set + process page file usage): 937112Kb/2097024Kb (44%)
    
Global physical memory: 1683568Kb/2619896Kb (64%)
    
Global commitable memory (physical + pagefile): 2480072Kb/5235924Kb (48%)

 


System info:
COMPUTERNAME = POTATO
APPLICATION = "C:\Games\World_of_Warships\worldofwarships.exe" wows_wait_for_mutex
2 PROCESSOR(S) = 0 - 6 f06
DISPLAYDEVICE 0 = \\.\DISPLAY1, NVIDIA GeForce 210 , PCI\VEN_10DE&DEV_0A65&SUBSYS_00000000&REV_A2
DISPLAYDEVICE 1 = \\.\DISPLAY2, NVIDIA GeForce 210 , PCI\VEN_10DE&DEV_0A65&SUBSYS_00000000&REV_A2
DISPLAYDEVICE 2 = \\.\DISPLAYV1, RDPDD Chained DD, 
DISPLAYDEVICE 3 = \\.\DISPLAYV2, RDP Encoder Mirror Driver, 
DISPLAYDEVICE 4 = \\.\DISPLAYV3, RDP Reflector Display Driver,

This is what showed up in the Event Log of the crash:

 Faulting application name: worldofwarships.exe, version: 0.5.2.4, time stamp: 0x56a94645
Faulting module name: MSVCR110.dll, version: 11.0.51106.1, time stamp: 0x5098858e
Exception code: 0x40000015
Fault offset: 0x000a327c
Faulting process id: 0x114c
Faulting application start time: 0x01d160c14ebf0d13
Faulting application path: C:\Games\World_of_Warships\worldofwarships.exe
Faulting module path: C:\Games\World_of_Warships\MSVCR110.dll
Report Id: 5e7b0240-ccb5-11e5-b70e-0019dbdc7fa3

I hope this info would help in fixing my problem.

Edited by spider4929

Share this post


Link to post
Share on other sites

×