Jump to content
You need to play a total of 10 battles to post in this section.
HIMYM

FPS Issue - Please Help !

25 comments in this topic

Recommended Posts

0
[88AD]
Beta Tester
12 posts
4,054 battles

Hello Captains,

I recently had a clean install of windows 8.1 and now I get very bad fps.

My Laptop specs are as follows :

ASUS RoG GL551JW

CPU : i7 4720HQ

GPU : Nvidia 960M - 2GB

Integrated Chipset : Intel HD Graphics 4600

RAM : 16 GB

OS : Win 8.1

 

Before I used to get around 60 FPS and Very High settings but now I can barely manage 40 on the Low.

Appreciate any help :)

Share this post


Link to post
Share on other sites
Member
70 posts
4,674 battles

Maybe the game is now using the integrated Intel HD Graphics.  If the above post does not fix it see if there is an option to disable the Intel card in your GFX option, if not there should be an option to turn it off in the Bios at boot up.

Share this post


Link to post
Share on other sites
0
[88AD]
Beta Tester
12 posts
4,054 battles

Go to amd or nvidia control panel and set the power to maximum or the power management and set to max perfor too

 

It is already in max performance.. I tried all the regular fixes but to no avail..

Share this post


Link to post
Share on other sites
0
[88AD]
Beta Tester
12 posts
4,054 battles

Maybe the game is now using the integrated Intel HD Graphics.  If the above post does not fix it see if there is an option to disable the Intel card in your GFX option, if not there should be an option to turn it off in the Bios at boot up.

 

I used MSI afterburner to see my GPU activity and it was being used to max.. :(

Share this post


Link to post
Share on other sites
Beta Tester
812 posts
2,681 battles

Hmm it might be an outdated driver that are not compatible to your new 8.1 since they were installed for the old OS or just really outdated drivers. Might be a good time to check and update if there is

Share this post


Link to post
Share on other sites
Member
211 posts
9,931 battles

 

I used MSI afterburner to see my GPU activity and it was being used to max.. :(

 

Strange, i have to ask if the resolution has changed or something?

 

Share this post


Link to post
Share on other sites
0
[88AD]
Beta Tester
12 posts
4,054 battles

 

Strange, i have to ask if the resolution has changed or something?

 

 

No.. Always use the 1920x1080

This is really worrying me..

 

Share this post


Link to post
Share on other sites
Beta Tester
183 posts
5,186 battles

check your HDD for bad sector or maybe your processor is throttling........

my friend had the same problem, then he change the HDD to SSD and the problem solved.........

Share this post


Link to post
Share on other sites
Member
892 posts
7,853 battles

I recently upgraded my rig's GTX750ti to a GTX970 and to my dismay, fps count was relatively unchanged. My NVidia 3D setting has only one setting changed under both cards' which is "Preferred Maximum Performance".

Share this post


Link to post
Share on other sites
0
[88AD]
Beta Tester
12 posts
4,054 battles

yes windows 10 will help

not sure if it is still a free download now or not.

 

It is still available.. I'll update and keep you guys updates.. thanks for help :)

Share this post


Link to post
Share on other sites
Member
124 posts

Maybe this could help in multi-GPU laptop:

 

Go to "Nvidia Control Panel".

Go to "Manage 3D Settings".

Under "Select a program to customize", select World of Warships. If it's not available, click "Add" and find worldofwarships.exe.

Under "Select the preferred graphics processor for this program", select "High-performance NVIDIA processor".

 

Good luck.

Share this post


Link to post
Share on other sites
Member
892 posts
7,853 battles

I've been "tweaking" my Nvidia Control Panel settings along with the game video settings. Am close to getting a good compromise for smooth yet good looking game play. Been getting my FPS between 70+ and below 10, which happens occasionally. Averages around mid 30s. Will share more when I'm done.

Share this post


Link to post
Share on other sites
Alpha Tester
184 posts
2,083 battles

 

You think that would help ?

 

 

Ever since I upgraded to Windows 10 the performance is better. Maybe 8.1 is already using alot of your systems resources with background programs, so when you run the game it does not perform well. Install Windows 10 or do a clean up of the post operating system install files, defrag etc update all drivers.

Share this post


Link to post
Share on other sites
Member
211 posts
9,931 battles

If you are still having the issue, 

I ran into a similar problem (down to 20 FPS slideshow), checked Task manager for what Taxing my system so badly

the culprit was an ASUS program

atkexComSvc.exe has a known memory leak issue (showed in Task manager with excessive amounts of memory usage for a background program)

 

So search through your task manager looking for abnormally high CPU, Mem usage programs. 

do a google search on to determine exactly what it is and if it has known issues.

 

But just to be sure i also recommend looking through Nvidia Control Panel or Experience (whatever they call it nowadays) make sure its not doing something silly like forcing x16AA on a hardware level

and check anisotropic filtering in game, AA and AF are very taxing on the system.

Edited by Apex1o1

Share this post


Link to post
Share on other sites
Member
27 posts
2,986 battles

last 3 games have been virtually unplayable...4-6fps 150ms lag...never seen it that bad before. i7 cpu 960 @ 3.2ghz. GTX 690 vc. 12gb ram...normally get 70+fps so its not the pc....

 

Share this post


Link to post
Share on other sites
Beta Tester
93 posts
2,456 battles

Am also getting frame drops last 2 weeks. No software or hardware changes cept for wows patch...

Running strix 960 and previously it sat at 71 fps never really dropped below 62. Now it bounces all over the place at rather irregular intervals.


 

Edited by Addos

Share this post


Link to post
Share on other sites
Member
70 posts
4,674 battles

Just did this myself if you are running NVidia and Geforce experience.  Load GE up when you pick the option to DL new gfx driver select custom install then tick the clean install box.  After that load experience and optimise for WOW.  My FPS has gone up probably because I had an old profile for it, the clean install box makes a new profile for the game.

Share this post


Link to post
Share on other sites
Member
892 posts
7,853 battles

Am also getting frame drops last 2 weeks. No software or hardware changes cept for wows patch...

Running strix 960 and previously it sat at 71 fps never really dropped below 62. Now it bounces all over the place at rather irregular intervals.

 

 

 

Mind sharing your Nvidia control panel and in-game settings?

Share this post


Link to post
Share on other sites
Beta Tester
93 posts
2,456 battles

 

Mind sharing your Nvidia control panel and in-game settings?

 

Just using default nvidia setting cept for full colour ctrl (hdmi). No power tweaks or anything, application controlled.

In wows use the very high preset setting, 1080p.

Nothing tricky. Hope this helps!

Share this post


Link to post
Share on other sites
Member
892 posts
7,853 battles

 

Just using default nvidia setting cept for full colour ctrl (hdmi). No power tweaks or anything, application controlled.

In wows use the very high preset setting, 1080p.

Nothing tricky. Hope this helps!

 

No such luck for me.... I even did a clean re-install of NVidia drivers but to no avail ie, fps is still all over, averaging between 20s to 40s with occasional dips to below 10. I did notice during occasions when fps dips below 10, there were "lag" warnings too

Share this post


Link to post
Share on other sites

×