Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
Luthais

Cannot research new ship.

5 comments in this topic

Recommended Posts

Member
11 posts
1,223 battles

Am trying to purchase a premium ship. Now maybe I am going wrong somewhere so correct me if I do.

 

1.    I go to the tech tree,

2.    Select my nation then choose one of the gold ships on the right.

 

When I choose the ship I desire, it comes up with a window which asks me to research it. Written in gold it says 'Premium Ship Benefits'. The first on the list is 'No Research Required'. When I press the 'Research' button the game comes up with a confirmation window which says 'Research the ship for..' and a Yes or No answer. either button does not work as the game is now frozen.

 

Apologies if anyone has had this as well.

 

Share this post


Link to post
Share on other sites
Member
11 posts
1,223 battles

I suppose that is a relevant question.  

 

Yes, when I select the warship, a pop up window appears with the research price which is zero of course and the cost price. And yes I have ample gold for the purchase.

 

It is freezing the screen. I have to task manager to exit the game too and there is no 'not responding' next to it either.

 

 

Share this post


Link to post
Share on other sites
147
[BLUMR]
Member
1,134 posts
1,377 battles

Are you running any mods? Sounds like you're using the extended tech tree mod that shows all the ships (inc. prems) and you're trying to research one of them.

Share this post


Link to post
Share on other sites
Moderator
4,163 posts
1,874 battles

Yeah, which premium ship are you trying to purchase? This exact sequence appears to be the one that happens if you try to buy a premium from the tech tree that's not supposed to be for sale on the tech tree.

 

 

Share this post


Link to post
Share on other sites
Sign in to follow this  

×