Jump to content
You need to play a total of 10 battles to post in this section.
beanhero

Cant update WOWs on Mac

8 comments in this topic

Recommended Posts

Member
1 post
102 battles

hey guys

 

So, i've downloaded the mac client for WOWs (code weavers) but i don't seem to be able to update, since every time i try, it says 'critical error'. Is this because of my mac's version or just there is a bug in the mac client?

Share this post


Link to post
Share on other sites
Member
64 posts
10,382 battles

Hi Bean

 

when updating disable the torrents under settings when doing updates, doing that that stops future messages when doing updates. Also make sure to have the current version from code weavers which is 1.0.7 as that helps with some other issues.

 

have Fun

 

Frank

Share this post


Link to post
Share on other sites
Member
621 posts
2,271 battles

WOWS is only available on Microsoft OS...

Didnt know there a Mac client version...

 

CodeWeavers has a wineskin wrapper for WoWS that works on Mac. I use it myself and it works perfectly fine (albeit with very occasional sound glitches).

 

>using mac to play games. :D

 

I happen to have to use a Mac because of school (only Macbooks are allowed, don't ask me why). In some cases, people don't want to buy a second computer just for gaming, or just don't have the opportunity :/

Share this post


Link to post
Share on other sites
Member
621 posts
2,271 battles

Just bootcamp and install Windows 7/8/10 alongside Mac OS X. Problem solved!

 

Lazy :D

 

Just kidding, it's just that I haven't really needed to for now.

Share this post


Link to post
Share on other sites

×