Jump to content
Sign in to follow this  
You need to play a total of 10 battles to post in this section.
yanyatcheng

lag after update, ghosts ship

3 comments in this topic

Recommended Posts

Member
295 posts
501 battles

after this update, problem starts appearing, 

first, it's the lag, I have a 2-5 second lag (after any of my commad: fire, team chat ect.) and from 100% a-ok with this game to getting kicked because of lag (back to log in screen), and the game shows I have -35 ping (WTF:hiding:)

 

than, it's the "ghosts cruiser" that I can only see DDs, I've encountered a cleveland in my cleveland, in a water channel, under 10km, I can see this shell flying over me, and a "unknown" marker on map, but I can't spot him even I have no island between me and the enemy CA, it's kind of wierd. and than I found a enemy Omaha also having the same problem for me, he can spot me in a open sea, but I can't spot him under 14km range.... 

*there's no smoke

Share this post


Link to post
Share on other sites
Member
295 posts
501 battles

can't get screen shots, I thought it was just normal until I saw the second ship. and because of the weird spotting mechanics of WoWS I though it's all normal.

 

it's like a cruiser/battship with destroyer detaction range 

 

just to explain how do I know both ships: I saw the first ship retreating and firing 6 per salvo, must be a clevland. second ship, firing a gun at a time with rapid fire, sometimes two shell in a time

Share this post


Link to post
Share on other sites
Sign in to follow this  

×