Jump to content

Lynman_Alpha

Member
  • Content Сount

    5
  • Joined

  • Last visited

  • Battles

    323

About Lynman_Alpha

  • Rank
    Ensign
  • Birthday 06/23/1999
  • Insignia

Profile Information

  • Gender
    Male
  • Location
    Philppines
  1. Lynman_Alpha

    IT CRASHES!

    Yep, it fixes but sometimes, it happens again. Luckily it didn't crash during the battle, only in loading screen before the battle.
  2. Lynman_Alpha

    IT CRASHES!

    I've tried and it fixes... I hope it will run smoothly for a long run
  3. Lynman_Alpha

    IT CRASHES!

    https://www.facebook.com/photo.php?fbid=1002154043161808&set=a.369841599726392.79443.100001016662267 ^^Here is the link ^^ (I hope you can see that photo) [i'm just new here in forum]
  4. Lynman_Alpha

    IT CRASHES!

    I just played WoWs today and it plays pretty normal... I don't know why it happens. I use Razer Cortex to boost the game.... I have no mods installed...
  5. Lynman_Alpha

    IT CRASHES!

    Hi guys! I need your urgent help... I've been playing World of Warships for about 5 months and this problem just happen for the first time. I launch the game smoothly but when I start "Battle", the problem starts. Whenever I am the one who will be loading, the game crashes. I don't know why. Here is some of my laptop's specs: OS: Windows 10 Home System Model: Aspire E1-470 Processor: Intel Core i3 Graphic Card: Intel HD Graphics 4000 Memory: 4096 MB RAM DirectX Version: 11.2 Please help me....
×