Jump to content

JohnnyTooGood

Member
  • Content Сount

    17
  • Joined

  • Last visited

  • Battles

    9522

Community Reputation

4 Neutral

About JohnnyTooGood

  • Rank
    Lieutenant (junior grade)
  • Insignia

Recent Profile Visitors

666 profile views
  1. JohnnyTooGood

    Soo who is still staying in the SEA server?

    The CN_70 clan are a well-known BOT farming clan on the ASIA servers! One reason why I'm moving to the NA server, I'm sick of the amount a BOT farming clans on the ASIA server.
  2. JohnnyTooGood

    Clan Battle personal assignments not showing

    Steel would be great! I see the mission/personal assignments are now available again.
  3. JohnnyTooGood

    Clan Battle personal assignments not showing

    RANZN Clan received no steel today aswell
  4. JohnnyTooGood

    Error Connecting to Server

    As far as I can tell its been down for 8 hours or so
  5. JohnnyTooGood

    Error Connecting to Server

    Frontpage of the website DUE TO TECHNICAL ISSUES, YOU MAY ENCOUNTER PROBLEMS WITH AUTHORIZATION ON THE SERVER. WE ARE DOING OUR BEST TO FIX THE PROBLEM
  6. JohnnyTooGood

    Error Connecting to Server

    I'm feeling the burn as well! I guess there are trying to fix the issue?
  7. JohnnyTooGood

    WarGaming, Please remove Rental ships for Ranked

    You should have to pay to rent, rental ships. This would make players invest more into their gameplay while in a ranked battle. It's not renting when it's FREE to play!
  8. JohnnyTooGood

    WarGaming, Please remove Rental ships for Ranked

    You should have to pay to rent a rental ship. This would make players invest more into their gameplay while in a ranked battle. It's not renting when it's FREE to play!
  9. JohnnyTooGood

    WarGaming, Please remove Rental ships for Ranked

    I agree! war gaming needs to do a better job of an unfair battle and balance the playing field. I just played a game with four rental ships on my side and the other side had none. YET ANOTHER LOST!
  10. For the love of this game, please remove the RENTAL ships from the Ranked season! These players don't understand how the play their selected ship and so will ruin the ranked season for everyone else! It's ok in Clan Battles as players are on comms, and have their teammates to help but, rental ships don't belong in ranked! How can you rank to 'ONE' when the whole team has to carry these players.
  11. JohnnyTooGood

    My Clan has dissappeared. What happened?

    If you're an Aussie or Kiwi English speaking player we would love to have you! Cheers [RANZN] JohnnyTooGood
  12. Fractal Meshify C Mid Tower Case
    Operating System: Windows 10 Home 64-bit
    CPU: Intel Core i7 4790K @ 4.00GHz Haswell 22nm Technology + NZXT Kraken X52 Liquid Cooler
    RAM: 16.0GB Dual-Channel DDR3 @ 799MHz
    Motherboard: Gigabyte Technology Co. Ltd. Z97X-UD3H-BK-CF
    Graphics: ROG PG279Q (2560x1440@144Hz), NVIDIA GeForce GTX 1080 Ti + NZXT Kraken G12 Adaptor + NZXT Kraken X52 Liquid Cooler 
    Storage: 2x 256GB Raid Volume, 2x 2TB Western Digital HD, 1x 256GB ADATA SX8000NP

  13. JohnnyTooGood

    Operation Cherry Blossom bug

    I noticed a 10-15 frame rate drop in the new operation.I normally sit 74-77fps in all games. Plus so far i never get you see the battle results just kicks me back to the port. I'm not the only one having this problem, clan mates are also having this problem.
  14. JohnnyTooGood

    FPS drops since recent update

    Thanks for the breadcrumbs! I finally found this post from War Gaming.
  15. JohnnyTooGood

    FPS drops since recent update

    I see no one has posted this yet on the Asia forums so I will, heaps of posts about this on the US forums. Operating System: Windows 10 Home 64-bit CPU: Intel Core i7 4790K @ 4.00GHz Haswell 22nm Technology RAM: 16.0GB Dual-Channel DDR3 @ 799MHz Motherboard: Gigabyte Technology Co. Ltd. Z97X-UD3H-BK-CF Graphics: ROG PG279Q (2560x1440@144Hz), NVIDIA GeForce GTX 1080 Ti Storage: 2x 256GB Raid Volume, 2x 2TB Western Digital HD, 1x M.2 256GB My frame rates "before" the most recent update ran around 73 to 75 FPS then "after" the most recent update I am getting drops in frame rates to about 50 FPS making the game hard to play. I find this is happening after every 4 to 6 games and I have to restart WoWS. Its feels like lag but my ping doesn't seem to change. Several clan members are have the same issue and are running high-end gaming PC's. I checked my GPU and CPU usage during low frame rates and high frame rates and my GPU and CPU never go above 30-40% usage and temps our great (water cooled). I also checked memory usage and bus usage and all was normal and showed no signs of being stressed. Just want War Gaming to see the post, Feel free to throw in your two cents!
×